Help & Support

Reply
newcomer
edd_mac
Posts: 1
Registered: ‎21-05-2012

Cant send or receive mms on galaxy s3 mini.got internet

Mms
amysewell2505
Posts: 135
Topics: 8
Kudos: 27
Best Answers: 3
Registered: ‎26-12-2011

Re: Cant send or receive mms on galaxy s3 mini.got internet

Have you got mms settings on? I turn mine off because sometimes iMessages on
My iPhone when sending a photo goes to mms so I turn it off to avoid extra charges. Maybe your Samsung has this feature and it's accidently off?
harrybee1980
Posts: 11,428
Topics: 27
Kudos: 1,619
Best Answers: 1,969
Registered: ‎06-10-2012

Re: Cant send or receive mms on galaxy s3 mini.got internet

[ Edited ]

Make sure you have credit as mms are not goodybag inclusive and cost 16p each ti send.

Also make sure WiFi is off and mobile internet is on.

Get a free giffgaff Sim
amysewell2505
Posts: 135
Topics: 8
Kudos: 27
Best Answers: 3
Registered: ‎26-12-2011

Re: Cant send or receive mms on galaxy s3 mini.got internet

Also mms cost extra 16p And do not come out of your Internet allowance so make sure you have credit
rayhoo
Posts: 38,283
Topics: 23
Kudos: 4,180
Registered: ‎21-07-2010

Re: Cant send or receive mms on galaxy s3 mini.got internet


edd_mac wrote:
Mms

Is your internet working okay?  Take a look here for more on how MMS works:  MMS Simply.

Get a free Giffgaff Sim

 

Gen. note: Text "PASS" to 43430 to confirm your username, account e-mail address, and to receive a password reset link.
harrybee1980
Posts: 11,428
Topics: 27
Kudos: 1,619
Best Answers: 1,969
Registered: ‎06-10-2012

Re: Cant send or receive mms on galaxy s3 mini.got internet

Just to add some phones require sending oneself a mms to initiate it. So try sending yourself one.
Get a free giffgaff Sim
ratty1987
Posts: 189
Topics: 2
Kudos: 12
Best Answers: 10
Registered: ‎07-09-2012

Re: Cant send or receive mms on galaxy s3 mini.got internet

Make sure you have credit on your phone. 16p per message
jokeyboi77
Posts: 22,106
Registered: ‎07-10-2011

Re: Cant send or receive mms on galaxy s3 mini.got internet

Hi Edd :smileyhappy:

Make sure you have the green circle activated next to your MMS access point name.

If you haven't here's how you do it mate.

Go to settings> then click more settings in the wireless&network section> then click mobile networks> then Access Point Names> and make sure you have the giffgaff settings switched on. :smileyhappy: