Help & Support

Reply
beginner
neil4636
Posts: 60
Registered: ‎19-04-2012
Best Answer

iMessage iphone

Hi all, I am having trouble getting my iphone to activate iMessage since switching to giffgaff. Just always says "activation unsuccessful" Internet works fine. Apple account fine. I don't know what the problem is! Hope you can help, Neil
jmistry
Posts: 9,357
Topics: 6
Kudos: 837
Best Answers: 671
Registered: ‎20-12-2010

Re: iMessage iphone

It normally sends a text out to activate.  Do you have credit or a goodybag avaialble to do this?

Get a free giffgaff Sim
sydbrazil1
Posts: 6,937
Topics: 133
Kudos: 490
Best Answers: 161
Registered: ‎15-08-2011

Re: iMessage iphone

Try switching it off & on
Get a free Giffgaff Sim
usmanozzy786
Posts: 18,272
Topics: 1,060
Kudos: 1,725
Blog Posts: 0
Ideas: 82
Best Answers: 602
Registered: ‎24-02-2011

Re: iMessage iphone

If Imessage is a application delete it and reinstall is
Get a free giffgaff Sim
sloz
Posts: 45,863
Registered: ‎27-11-2009

Re: iMessage iphone

The problems arise from the settings profile you installed from the link you recieved by texting settings to 2020
You must delete this profile
Go to settings- general- profile
(Profiles is near the bottom)

Now go to safari and install these settings
Http://invalid.name/giffgaff
(by deleting the previous profile your Internet will not connect so use wifi or go to settings- general- network- mobile data network
And change the mobile data apn to giffgaff.com
That will enable you to install the new profile)

Once installed all that's required is to change the mms settings a little
Go again to settings- general- network- mobile data network
And change the mms apn from
Idata.o2.co.uk to giffgaff.com
And the mms username from
Vertigo to giffgaff
Don't click reset.
All apps and sites that previously gave errors before should now work
heavy hitter
adnanasim80
Posts: 3,678
Registered: ‎04-11-2011

Re: iMessage iphone

Fixed the issue by doing:

1) Switched off Face Time (Setting -> FaceTime-> FaceTime OFF)
2) Switched off iMessage(Setting -> Messages->iMessage OFF)
3) Switched on iMessage (The phone started “Verifying”the incorrect phone number, failed and set it to the correct ported number (seeSettings -> Messages -> Receive At -> Phone).
4) At this point the “My Number” (Settings ->Phone -> My Number) had also updated.
5) Switched on Face(Same “Verifying” as with iMessage, but tooktwo attempts).
6) Power Cycled the ‘phone and re-synced to updateiTunes If necessary (Summary “Phone Number” field).

sydbrazil1
Posts: 6,937
Topics: 133
Kudos: 490
Best Answers: 161
Registered: ‎15-08-2011

Re: iMessage iphone

Connect to Wifi > to go Message > iMessage > Switch Off & On > Wait 2mins for Activation
Get a free Giffgaff Sim
nadzzz_p
Posts: 2,617
Topics: 23
Kudos: 171
Best Answers: 70
Registered: ‎10-11-2011

Re: iMessage iphone

Get the settings again, and restart your ohone for it to take effect...if this doesnt work, contact apple
arj95
Posts: 4,420
Topics: 191
Kudos: 266
Best Answers: 79
Registered: ‎09-04-2011

Re: iMessage iphone

Reboot your iPhone then do this. I think I solved the problem, well that's for mine anyway. Delete giffgaff’s profile in settings. Turn off iMessage. Leave 3G and cellular data on. Turn off wifi. Do a hard reboot (hold home and lock button together till Apple logo shows). Go to settings. Make sure 3G and cellular data is on with wifi off. Go to iMessage and activate it without using Apple ID. There you go.
Order a FREE giffgaff sim with £5 FREE credit, click on the banner belowGet a free giffgaff SimClick the yellow stars (kudos) on the left if I helped! Also accept as solution if it's a good response! Thanks alot!
beginner
neil4636
Posts: 60
Registered: ‎19-04-2012

Re: iMessage iphone

Thanks. Now fixed!