Reply
newcomer
Posts: 10
Registered: ‎02-07-2012
Best Answer

imessage caller ID greyed out and e-mail is seen in the subject field

Hi

 

I have a 3gs iphone which sends my e-mail as the sender. I have re booted and have latest update. My phone number is displayed in my phone > settings. I have turned off/on imessage. Gone to caller id and selected my phone number. But still my phone number is greyed out and only my e-mail is available for selection.  Cant find anything else on here to solve the problem other than turning off iMessage.

 

Any help please

 

Many thanks

Best Answer
Chosen by topic author pazaboy
Posts: 490
Topics: 14
Kudos: 80
Best Answers: 29
Registered: ‎07-07-2011

Re: imessage caller ID greyed out and e-mail is seen in the subject field

You could give this a try:-
First see in https://appleid.apple.com if the apple ID is linked with the iPhone phone number, if not, modify and save changes, then in the iPhone go to settings -> messages -> and deactivate iMessage and activate it again (the correct phone number should appear in "Receive At" greyed out). Do the same in settings -> FaceTime. After that reboot your iPhone
Get a free Giffgaff Sim

View Best Answer in original post


All Replies
Posts: 3,581
Topics: 19
Kudos: 436
Best Answers: 113
Registered: ‎13-06-2012

Re: imessage caller ID greyed out and e-mail is seen in the subject field

If you go on settings -----> phone you will be able to edit your phone number. Then turn iMessage off/on this should reactive iMessage with the correct number
Get a free giffgaff Sim
scholar
Posts: 1,661
Registered: ‎08-05-2012

Re: imessage caller ID greyed out and e-mail is seen in the subject field

Posts: 2,676
Kudos: 246
Registered: ‎19-02-2011

Re: imessage caller ID greyed out and e-mail is seen in the subject field

Have you gone to settings>message, scroll down to receive at and selct it, go to caller ID, and change it there?

Get a free Giffgaff Sim
Has your question been answered? Don't forget to ACCEPT A SOLUTION
Have I helped? Click on my star Smiley Wink
trainee
Posts: 52
Registered: ‎21-05-2011

Re: imessage caller ID greyed out and e-mail is seen in the subject field

Does it say 'Waiting for activation' or have you recently update to the latest version of iOS?

 

 

Best Answer
Chosen by topic author pazaboy
Posts: 490
Topics: 14
Kudos: 80
Best Answers: 29
Registered: ‎07-07-2011

Re: imessage caller ID greyed out and e-mail is seen in the subject field

You could give this a try:-
First see in https://appleid.apple.com if the apple ID is linked with the iPhone phone number, if not, modify and save changes, then in the iPhone go to settings -> messages -> and deactivate iMessage and activate it again (the correct phone number should appear in "Receive At" greyed out). Do the same in settings -> FaceTime. After that reboot your iPhone
Get a free Giffgaff Sim
newcomer
Posts: 10
Registered: ‎02-07-2012

Re: imessage caller ID greyed out and e-mail is seen in the subject field

Tried that didnt work. Thanks
newcomer
Posts: 10
Registered: ‎02-07-2012

Re: imessage caller ID greyed out and e-mail is seen in the subject field

Didnt work first thing i tried. Thanks for trying to help tho
newcomer
Posts: 10
Registered: ‎02-07-2012

Re: imessage caller ID greyed out and e-mail is seen in the subject field

Yep done that. Selected my phone number under caller ID but still greyed out under 'receive at'
Posts: 850
Topics: 38
Kudos: 94
Best Answers: 23
Registered: ‎28-05-2012

Re: imessage caller ID greyed out and e-mail is seen in the subject field

IIRC your number has to start with the +44 dropping the first 0 .

That should sort it . Smiley Happy

Giff Gaff SIM'S sent by 1st Class Post , Dont be left waiting for ages , get it the next day ..PM me please. All types available.
Get a free giffgaff Sim
If I've helped you solve an issue then give me some Kudos :-)