Tips & Advice

Reply
student
natstally
Posts: 170
Registered: ‎18-07-2010

Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

[ Edited ]
Hi, after a few similar questions over the past few days i thought i'd add this post to this board where hopefully it will be of use. 
While helping someone on the forums who was having trouble sending emails i discovered i couldn't send email from my TalkTalk account on my phone either!  After a bit  of trial and error and some searching on here, i found out it was the outgoing server that needed changing.
Some mail providers require you to use your mobile network (giffgaff)'s smtp server to send mail from your mobile, NOT the their own.

In this case, to send emails on giffgaff use - smtp.O2.co.uk in place of your usual outgoing server.
 
 So all settings for TalkTalk are as follows;

  • E-mail address: username@talktalk.net
  • Incoming mail Sever: mail.talktalk.net 
  • Outgoing mail (SMTP) Server: smtp.O2.co.uk  (Select the smtp server for your network provider - in this case, GG/O2.)
  • Account name (Username): username@talktalk.net
  • Password: Your TalkTalk email password

If you are asked, please input the following details also: 

  • Incoming mail account type: POP3
  • Incoming mail port: 110
  • Log on using SPA: leave unchecked
  • Authentication: none
  • Outgoing mail port: 25 Use SSL: leave unchecked
 During my trial and error, i noticed i could send mail from my Sky.com account with no problems, i didn't need to use the O2 server.
 Settings for Sky are as follows;
 
Your Incoming Mail Server requires SSL.
The Incoming mail server for POP3 is pop.tools.sky.com.
The Incoming mail server for IMAP is imap.tools.sky.com.
Where you see the Use SSL option, select yes.
The port for POP3 is 995.
The port for IMAP is 993.
Where you see the Outgoing Mail (SMTP) Server requires SSL option, select yes.
Where you see the smtp.tools.sky.com (use authentication) option, select yes.
Where you see the Use Authentication option, select yes.
Where you see the Use STARTTLS option, select yes (some clients call this SSL).
The port for outgoing mail is 465.
Where you see the Account Name option, use your Sky Email username (including @sky.com).
Where you see the Email Address option, use your full Sky Email address (username@sky.com).
If you are asked for your password, use the Sky Email password you used to sign into webmail and adjust your settings.
 
These settings are taken from the TalkTalk and Sky websites.
 
 If anyone would like to add any other email providers that require you to use your mobile network's smtp server to this thread
I'm sure it could help others having the same problem eg.
 
 TalkTalk - Use O2 smtp
 Sky - Use Sky's own smtp
 
There is another thread listing Gmail, AOL, Yahoo, Hotmail  here so i won't go into those. (Also I'm really only posting from my own experience so that's Sky and TT :smileyhappy:)

 I'm sorry if this had been posted somewhere obvious before, i don't want to step on anyone's toes but it seemed that people were having trouble finding this info, hopefully it can help someone here :smileyhappy:
newcomer
ivan
Posts: 20
Registered: ‎31-01-2010

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

Hi after struggling to set up email on my nokia n95 8gb I read your post, and all is now good, I use a freeola email account and the 02 settings in combo with the freeola info work a treat,, hope this can be of use to other giffgaffers out there!!!

 

 

PS keep up the good work

 

Ivan

Genius is Mysterious!
newcomer
mdougill
Posts: 29
Registered: ‎11-10-2010

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

Hi All

 

Thought this may be of some use ?

 

I have been trying to get my email working although when using  the O2 mail servers my phone will not receive emails when it is connected to my wireless at home, i have tried using the virgin servers as outgoing but had the same problem of when i am away from home and not connected to my wirelass it will not send emails,

 

I did find a solution

 

Set up an email account with googlemail and use their mail servers:

 

this will then work whatever connection you are using.

 

 

Outgoing mail server (smtp) = smtp.gmail.com (Port 587 with TLS)

 

 

username

xxxxx@googlemail.com

 

or whatever your googlemail email is

 

Then use the password that you use to login to your googlemail account

 

 

and all should work fine,

 

Regards

 

Mark

 

 

 

 

adamboutcher
Posts: 616
Kudos: 279
Registered: ‎03-07-2010

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

newcomer
keith_mawdsley
Posts: 2
Registered: ‎12-03-2011

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

Hi, not finding the answer unfortunately.

 

I have a Nokia N8 just gone on to giffgaff, received the settings by test and installed OK.

 

I want to be able to send and receive from multiple email accounts if I'm at home, at work or sat by a lake. Therefore not relying on wifi I want to use the mobile network to send/receive. ATM I am receiving OK on wifi, not tried any other method for that yet. However sending an email just doesnt work.

 

in the account settings I have:

 

UA: None

Username; blank

outgoing mail server: mail.o2.co.uk

Access Point in use:giffgaff WAP

Security off

Port:default (have also tried manual on 25)

 

I have a 10.00 shopping bag for now but no 'credit'

 

When I do a sync I can get mail via wifi, but cannot send, Error message that comes up  is:

 

Conn Failed

Access Denied

 

in the top left corner. I tried my own settings for server, with and without authentication, but now I'm lost.

 

Any ideas please?

 

thx

gawright
Posts: 9,855
Topics: 38
Kudos: 1,868
Best Answers: 393
Registered: ‎29-06-2010

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

I think the outgoing server should be smtp.o2.co.uk rather than mail.o2.co.uk

Get a free Giffgaff Sim
newcomer
flipflopnick
Posts: 10
Registered: ‎31-07-2010

Re: Can't send emails? - SOLUTION - Email Settings for other POP3 accounts

[ Edited ]

mail.O2.co.uk and smtp.O2.co.uk resolve to the same IP address, so either will work. If usual port 25 does not work after several attempts, try port 26 see this thread
Port 25 worked for me without authentication on GG.

 

The following may help for POP3 email accounts not mentioned elsewhere. I use a mixture of all 3 methods below. If possible use IMAP connection to access your email. If only POP3 access, then ensure "leave mail on server" is ticked if you have another method to read email.

 

Sending POP3 email is a real nightmare when not connected by email provider. ie not using their broadband. Usually you use your ISP's SMTP server when at home. Plenty of advice from your ISP or Google.
Mobile GG users have a problem as GG do not offer a STMP server, but you can use any SMTP server. Does not need to be special 3g server. If email providers SMTP server does not work when mobile, try SMTP authentication ticked with "Use same login as POP3" also ticked, read on.

mail.O2.co.uk works as SMTP server for relaying email. Try it on GG without authentication on port 25 first, try port 26 if that does not work.  see this thread
You may have to have an O2 email address and use SMTP server authentication. see below for Howto

What you are trying to do is relay sending of email, which is what spammers try to do. So SMTP server providers try to stop you.

If you have a Gmail / Googlemail account you can use smtp.googlemail.com with port of 587 (not 25), but all mail will be sent to your Gmail account and all people will reply to your Gmail account. Try it. You will see. Using smtp.googlemail.com will not work with other POP3 accounts until you have authenticated other email addresses with your gmail account. visit www.google.com/mail and follow instructions to add more POP3 accounts in mail settings. How to do this changes too often, Google for latest method.  BTbroadband use similar  method.

Having your email address separate to your ISP / mobile provider is good. Can recommend Gmail and O2 for contacts, POP3 and IMAP access and webmail,  and mobile access.

Some SMTP servers will not relay anyone else's email no matter how much you try. PObroadband are one.

Some SMTP servers need to be POPped first. This "opens" them to sending email for a few minutes. So try Sending again immediately after first Receive. SMTP authentication may get round this double trouble.

If you do not want to get all correspondence in your Gmail account, then find friend with a domain name or hosting who does not mind you using their SMTP server. You  need to know their email address and password because you need to setup SMTP AUTHENTICATION to use their domain's SMTP server. Trusting friend! or get them to set up an email account for you alone so you can use their SMTP server.

eg domain is coniston-net.com
email address of user is michael@coniston-net.com
password is carl0sfandang0

so SMTP server would be smtp.coniston-net.com (or mail.coniston-net.com ???)
tick box for SMTP authentication for relaying of email
SMTP authentication login is usually full email address michael@coniston-net.com, password as above
sometimes login is only user name e.g. bit before @domain.name
play around with settings. (BTW this account does not exist :-)

or buy an SMTP relay service.

Do this for ordinary POP3 accounts except google mail, hotmail, yahoo mail for example who have their own SMTP server settings.
Above should work on desktops as well as clever mobile devices.

When connected via wifi, you could use broadband routers SMTP without SMTP authentication. Google for ISP's settings.

Using a different SMTP server to POP3 server scores highly on SPAM filters! AFAIK Yahoo! do not offer free POP3 access. BTBroadband email is different when provided by Yahoo!

 

Settings listed

If I have helped you, click the STAR on the left.
If your question is answered, click 'Accept as Solution' on the right.
1hale
Posts: 14,281
Topics: 615
Kudos: 2,970
Ideas: 26
Best Answers: 233
Registered: ‎08-09-2010

Re: Can't send emails? - SOLUTION - Email Settings for other POP3 accounts

For Yahoo mail do one of the following:

 

Visit http://uk.mobile.yahoo.com/mail

 

or

 

Use these settings to access Yahoo! Mail Plus using your favorite email reader.

Note: If you can't add new POP or new SMTP servers in your mail reader program, you need to change your current mail settings to access your Yahoo! Mail Plus account. Write down your current settings first—you may need to revert to them later if you want to use the same program to send and receive messages from your other email addresses.

Incoming mail server settings

  • POP server: plus.pop.mail.yahoo.com
  • Use SSL
  • Port: 995

Outgoing mail server (SMTP) settings

  • SMTP server: plus.smtp.mail.yahoo.com
  • Use SSL
  • Port: 465
  • Use authentication
  • Account Name/Login Name: Your Yahoo! Mail ID (your email address without the "@yahoo.com", for example, “testing80”)
  • Email Address: Your Yahoo! Mail address (for example, testing80@yahoo.com)
  • Password: Your Yahoo! Mail password

Troubleshooting tips

If you still can’t send Yahoo! Mail from your mail program, you may be accessing the Internet through an ISP that is blocking the SMTP port. If this is the case, try setting the SMTP port number to 587 when sending email via Yahoo!'s SMTP server.

Your email program gives you the option of either deleting your Yahoo! messages from the Yahoo! server after downloading them into your mail reader, or leaving them on the Yahoo! server so you can see them online in your Yahoo! account, too.

 

or

 

IMAP is another way you can get Yahoo! Mail on your phone. Using IMAP you can download messages with your mobile client, so you can access your mail even when not connected to the mobile Internet.

 

How to set up Yahoo! Mail with your mobile client using IMAP

  • On your phone, press < Home >, then open the Email application.
  • On the 'Your accounts' page, select Next to get started with setup.
  • Enter your full Yahoo! address and password, then select Next.
  • On the next screen, you can give the account a nickname and choose the name to display on your outgoing messages. Tap Done.

 

    If prompted, supply the following information:

  • Incoming Server - imap.mail.yahoo.com
  • Outgoing Server - smtp.mail.yahoo.com
  • Incoming Port - 993 (requires SSL)
  • Outgoing Port - 465 (requires SSL)
  • Username: full email address (bill@yahoo.com)
  • Password: is the password you login to Yahoo! with
student
natstally
Posts: 170
Registered: ‎18-07-2010

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

Thanks for the additions to the thread guys, seems there's all sorts of problems with email clients depending on all kinds of settings! Hopefully some useful points for someone :-)
newcomer
helkav
Posts: 4
Registered: ‎19-04-2012

Re: Can't send emails? - SOLUTION - Email Settings for TalkTalk and Sky.

@Ivan

I have a freeola account also, and I'm having problems sending from o2. Can you please give details of what you did to get it to work?