Get Help
Community

Android Voicemail Number Setting

Started by: alternative
On: 11/01/2010 | 23:58
Replies: 12
Reply

by: alternative
on: 11/01/2010 | 23:58
I have noticed that on my Samsung Galaxy Android 1.5 phone there is a similar problem to the one iPhone users face when using a giffgaff simcard. The Android phone recognises the giffgaff SIM as an O2-UK SIM and allocates the O2 voicemail number which is 901. Unfortunately, the giffgaff voicemail number is 111. When you try to change it in Settings/Call settings/Voicemail, it opens a box to type in the new number, but when you click OK you get the message "Voicemail number change unsuccessful". I have checked many Android forums and there doesn't appear to be a workaround. Of course you can always manually dial 111, but that doesn't extinguish the Voicemail Notification. The only way to extinguish it is to press "Voicemail" which still dials 901. Maybe the newer versions of Android address this problem?
Message 1 of 13 (5,428 Views)
by: andy0
on: 12/01/2010 | 02:31 edited: 17/01/2010 | 02:34

don't know, but maybe it needs the same approach I found for the iPhone - edit the carrier file, however that might be done for Android

 

I'm just browsing on a forum called precentral (guess what phones), which seems to be hinting at that ... but it's a bit late ...

Message 2 of 13 (5,419 Views)
by: alvintc
on: 12/01/2010 | 20:24

My Nexus allows me to select the number, so it looks like they fixed it.

------------------------------------
Google Nexus One user
Message 3 of 13 (5,394 Views)
by: alternative
on: 12/01/2010 | 20:41

Brilliant news alvintc. My new Nexus is scheduled for delivery any time now - can't wait! Anyone want a Galaxy?

Message 4 of 13 (5,390 Views)
by: alternative
on: 14/01/2010 | 10:44

Nexus One received OK and voicemail working on giffgaff. Having problems with MMS though.

The native messaging application on Android 2.1 doesn't seem to automatically resize camera shots for MMS, so they end up too large to send. I have been using Handcent, which does resize successfully, but rather too small (12kB or less). Today I can't seem to get any MMS to send successfully, yet last night it was fine. Settings unchanged. MMS does seem a bit flaky recently? Anyone else using MMS on an Android phone?

Message 5 of 13 (5,366 Views)
by: rb30inside
on: 16/01/2010 | 10:56

I hardly use MMS, but when i have used it, it seems to work.

 

I know this post is not much help.

_______________o-0___________________________
If my answer helps, then don't forget to give me a Kudos!!

Having problems setting up your Free GiffGaff data on your Definitive APN Settings list see here - http://community.giffgaff.com/t5/giffgaffer-Top-Tips/Definitive-APN-Settings-list/m-p/3266
Message 6 of 13 (5,346 Views)
by: danielclo1il
on: 16/01/2010 | 16:53

in regards to changing the iPhone's voicemail number..

 

 

Click the phone button in your iPhone. (Green one, bottom left)

Click the keypad tab.

Type the following: *5005*86*yourvoicemailphonenumber# (just google for your phone carrier’s voicemail number).

Hit the call button and wait a few seconds.
Hit the voicemail button, and it will now call your voicemail.

Thanks
Dann




Message 7 of 13 (5,336 Views)
by: andy0
on: 17/01/2010 | 02:41

danielclo1il wrote:

in regards to changing the iPhone's voicemail number..

 .


 

Thanks for the kind reply, but actually I wasn't asking for that.

 

There is in fact already another thread about altering the iPhone's voicemail number on the speed dial, where your method is mentioned, but for some people it doesn't work. I found and posted another solution, which was edit the carrier file, and that's why I suggested looking for an equivalent idea for Android phones

Message 8 of 13 (5,320 Views)
by: ceedee
on: 06/02/2010 | 13:44

I've read elsewhere that if you start your Android phone without the SIM in place, you're able to change the voicemail number.

Then turn it off and replace the SIM and, when you power up again, your phone should recognise your new voicemail number.

 

 

Kudos appreciated if this works for you...

Smiley Wink

Message 9 of 13 (5,176 Views)
by: benmurphy
on: 22/01/2011 | 13:13
All you have to do is flash the baseband, and it changes it automatically to 443.. or you can change it to what you want
Message 10 of 13 (4,035 Views)