Knowledge Base
Community

4G and WiFi

Started by: qwghlm
On: 06/11/2014 | 10:44
Replies: 12
Reply

Go to best answer
by: qwghlm
on: 06/11/2014 | 10:44

Hi,

 

I am on the 4G trial and notice that when I have WiFi enabled the signal drops from 4G to something much lower.

 

This is OK when I am at home because I use WiFi, but when out I have to turn WiFi off to get 4G.

 

Also, is there a way to stop WiFi trying to connect to  BT all the time when I am not at home?

 

I'd really like a setting where I can leave WiFi on that gives me full 4G and also stops the BT connection.

 

I have tried to "Forget" the BT connection but it just keeps coming back.

Message 1 of 13
1 BEST ANSWER

Accepted Solutions
Highlighted
by: tim74
on: 06/11/2014 | 11:24

If you just want it to be using wifi at home and then not trying to connect to everything while you are out you can usually put an app in your phone that can control wifi on/off depending on location so you could set it to be on at your home location and off while you are out.

Message 8 of 13
by: jazmin69
on: 06/11/2014 | 10:50
You should be able to manually switch off the wifi completely so it stops trying to connect to any network

Why would you need 4G and wifi at the same time.

My main phone is with EE and 4G and as far as I'm aware the 4g never works when in wifi, it doesn't need to, you're connection to the internet is with wifi then and 4G when you're out of range. The two don't work simultaneously
Get a free giffgaff Sim
Message 2 of 13
by: honeybunny19
on: 06/11/2014 | 10:51
That should not be case. It is probably only the coverage in the area. It may change
Message 3 of 13
by: adr_123
on: 06/11/2014 | 10:59
it sounds like youre going to have to turn off your wifi permanently as it automatically connects
Message 4 of 13
by: bigdaveuk
on: 06/11/2014 | 11:02
when your home wifi trys to connect to another network B.T just click on it and your get options to forget this network, click on forget this network.
Get a free giffgaff Sim
Message 5 of 13
by: leonora1984
on: 06/11/2014 | 11:15
Am connection to my wifi at min and very slow
Message 6 of 13
by: alternative
on: 06/11/2014 | 11:21

If you have an Android phone you can get it to ignore WiFi with poor internet connectivity, by going to Settings/WiFi/Advanced/Avoid Poor Connections (tick this box)

Message 7 of 13
Highlighted
by: tim74
on: 06/11/2014 | 11:24

If you just want it to be using wifi at home and then not trying to connect to everything while you are out you can usually put an app in your phone that can control wifi on/off depending on location so you could set it to be on at your home location and off while you are out.

Message 8 of 13
by: qwghlm
on: 06/11/2014 | 15:41

I think you need te re-read my post, I don't want 4G and WiFi at the same time, I just don't want to keep on having to turn off WiFi everytime I leave home then turn it back on again when I get back home.

 

It's because BT tries to connect using WiFi that reduces the signal from 4G to something lower.

 

If I turn off WiFi when I'm out and have got a low rate connection the connection immediately goes to 4G.

 

So I just need something that stops every other WiFi from trying to connect other than my own WiFi.

Message 9 of 13
by: qwghlm
on: 06/11/2014 | 15:42

Don't want to do that as I use WiFi at home.

Message 10 of 13