Get Help

Connecting my iPhone 3Gs to the internet

Started by: georgebowie
On: 23/03/2012 | 11:00
Replies: 6

by: georgebowie
on: 23/03/2012 | 11:00

Hi I posted this query to a member:-

I have recently subscribed to an automatic topping up of my Account and had this confirmed! When trying to connect using 3G I get the message - Could not activate mobile data network - You are not subscribed to a mobile data service. What does this mean? How does one get this service on my fully paid up GiffGaff account?


Can you please help me?


Many thanks


George Bowie The reply gave me all the settings but suggested I contact the Community for technical advice as to HOW to enter the settings into my phone. I am an OLD CODGER and not very tech savvy.




Can anyone help?


Many thanks,


George Bowie







Message 1 of 7
by: morvin
on: 23/03/2012 | 11:02
You need correct settings. See here
Get a free Giffgaff Sim
Please give 'KUDOS' if you like my post. If my answer helped then please click 'Accept as Solution'
Message 2 of 7
by: mrcool073
on: 23/03/2012 | 11:05

First Try Texting Settings to 2020

if that fails to send your phone settings see below for your settings - How to giffgaff an iPhone 4 - How to giffgaff an iPhone 3G/3GS - Android guide
if you have wi-fi access, download the giffgaffAPN app from the Android Marketplace to set them up for you
or click here to download the giffgaff apn: -Samsung Galaxy S2 internet & MMS - How to giffgaff a Blackberry - Definitive APN Settings should work on all phones - Guide to Windows Mobile 6.1 - Nokia C3 -Nokia C5 - dongle settings

Message 3 of 7
by: gmob
on: 23/03/2012 | 11:23

If your running IOS 5.1 ....


Use these settings...


Go to "Settings"

Then "General"

Then "Network"

Then "Mobile Data Network"



Username   giffgaff

Password   password



Visual Voicemail(just leave as is, giffgaff do not support visual voicemail)






Username   giffgaff

Password   password


MMS Proxy

Max message size   2097152

MMS UA Prof URL   (just leave blank)



Do NOT press the 'Reset Settings' button once settings are input.


Once settings have been input  turn your iphone off and on again.


Please ensure that 'MMS Messaging' button is set to ON. (Press Settings, then Messages).


Please also ensure that the 'Enable 3G' button and the 'Mobile Data' button are set to ON. (Pess Settings, then General, then Network).


Also note that Picture messages cost 16p and are not included in any goodybag.


In " settings " " messages " turn imessages off and on.


Hope this helps. :smileyhappy:

Get a free giffgaff Sim
Message 4 of 7
by: bluemoonbaz
on: 23/03/2012 | 11:23
haha never too old george
see here
also have you got data goody bag ie £10. or payg credit to cover
hope all goes well if not re post for help
Message 5 of 7
by: adnanasim80
on: 23/03/2012 | 11:25

Enter these settings into your iPhone
(Select Settings -> General -> Network -> Cellular Data Network (or Mobile Data Network)
Cellular Data
Username: giffgaff
Password: password
Visual Voicemail
leave blank as giffgaff do not provide it
Username: giffgaff
Password: password
MMS proxy:
MMS Max Message Size: 2097152
MMS UA Prof URL: leave blank
Once you have manually entered these settings restart the Iphone and you should be on your way!

For more Info go here:

Message 6 of 7
by: rhort
on: 23/03/2012 | 11:30
To use and iPhone on the network, first try texting SETTINGS to 2020, which should sort it, however, if it doesn't, then try checking: (if you have an iPhone 4) (If you have an iPhone 3)
Message 7 of 7