Get Help
Community

How to turn on 3G on the Samsung s3

Started by: moksharma
On: 01/11/2012 | 16:11
Replies: 15
Reply

Go to solution
by: moksharma
on: 01/11/2012 | 16:11
I been trying for a week now guys but could not turn 3G ON. The galaxy s3 seems pretty simple to function other than where the heck is this turn 3G ON button? Cheers Smiley Wink
Message 1 of 16 (107,497 Views)
1 ACCEPTED SOLUTION

Accepted Solutions
by: rebelyell
on: 01/11/2012 | 16:15
Best Answer
Accepted by will23 (former giff-staffer)
‎21-08-2015 01:01
Go to System Settings>Wireless & Networks>Mobile Networks>Data Enabled

check the little box
Message 2 of 16 (112,512 Views)
by: rebelyell
on: 01/11/2012 | 16:15
Best Answer
Accepted by will23 (former giff-staffer)
‎21-08-2015 01:01
Go to System Settings>Wireless & Networks>Mobile Networks>Data Enabled

check the little box
Message 2 of 16 (112,513 Views)
by: paultheball
on: 01/11/2012 | 16:16
Open Settings then click MORE SETTINGS.
Then click MOBILE NETWORKS.
Ensure the
'USE PACKET DATA' box is ticked.

Get a free giffgaff Sim
Message 3 of 16 (107,486 Views)
by: rebelyell
on: 01/11/2012 | 16:18
Out of interest did you set up your phone to use giffgaff data?

If not you can use this app to help

https://play.google.com/store/search?q=tweakker+ics+apn+beta&c=apps

You'll need to run the app and follow the instructions.

Or you can do it manually

Go to:
System Settings>Wireless & Networks>Mobile Networks>Access Point Names

Name: giffgaff
APN: giffgaff.com
Proxy:
Port:
Username: giffgaff
Password: password
Server:
MMSC: http://mmsc.mediamessaging.co.uk:8002
MMS proxy: 193.113.200.195
MMS port: 8080
MCC: 234
MNC: 10
APN type: not set

Leave any other fields at the way they are.
Make sure you save your settings
Make sure your new APN is selected

If there's an option to select "use packet data" make sure this is selected.
Message 4 of 16 (107,484 Views)
by: jefferinho
on: 01/11/2012 | 16:19
The easy way
just hold the power button in until a menu opens up
You have the option to activate or deactivate mobile data from this menu
Simples
Message 5 of 16 (107,480 Views)
by: hunter4564567
on: 01/11/2012 | 16:22
Message 6 of 16 (107,476 Views)
by: nksoni_18
on: 01/11/2012 | 16:26

Ah and if nothing works you can reset your phone to default settings, take out the SIM card and put it back in after 10-15 sec to get back the new settings from the network 

 

Follow the on screen setup steps for android..

 

And then ... Happy Surfing .. Smiley Happy

Message 7 of 16 (107,473 Views)
by: moksharma
on: 01/11/2012 | 16:39
Guys thanks but tried all that. At the top right side it just says H+ and very rarely for about 5 seconds, 3G shows up automatically. Help help help plz
Message 8 of 16 (107,462 Views)
by: jpcjpc
on: 01/11/2012 | 17:13

H+ is better than 3G.

 

If you want to permanently enable 3g, go somewhere with worse reception and don't move. Ever.

 

Smiley Wink

Get a free Giffgaff Sim
Message 9 of 16 (107,456 Views)
by: greenman
on: 01/11/2012 | 17:17

Pull down Notification bar on home screen.

On right is the mobile data widge, but sounds like it's already on..............  and if on giffgaff unlimited data why turn it off??

Message 10 of 16 (107,447 Views)