Knowledge Base
Community

I have credit why can't I make calls from EU

Started by: debcard
On: 29/05/2015 | 18:42
Replies: 9
Reply

by: debcard
on: 29/05/2015 | 18:42
In Guernsey can't send txts even though I have credit
Message 1 of 10
by: rhort
on: 29/05/2015 | 18:43
When a handset fails whilst roaming, it's almost always down to the network detection settings having a manual option selected, rather than being set to 'Automatic'.

To remedy this, go to Settings > Mobile Networks

- On ANDROID this is Settings > Wireless & networks > Mobile Networks > Network Operators

- On BLACKBERRY select Manage Connection > Mobile Network > Network Selection

- On iOS it's Settings > Carriers

and make sure it's set to 'Automatic', which should then enable your handset to detect a local Airtime Provider. Once that is done, restart your handset, and it should connect to the local network.
Message 2 of 10
by: mcilwraith
on: 29/05/2015 | 18:44

try changing network provider

i think i used vodaphone last time i was there

Message 3 of 10
Highlighted
by: jumbo4
on: 29/05/2015 | 18:44

hi

try a manual roam to update and refresh your network connection. http://is.gd/manualroam

Get a free giffgaff Sim
Message 4 of 10
by: sufiic63
on: 29/05/2015 | 18:44
To remedy this, go to Settings > Mobile Networks

- On ANDROID this is Settings > Wireless & networks > Mobile Networks > Network Operators

- On BLACKBERRY select Manage Connection > Mobile Network > Network Selection

- On iOS it's Settings > Carriers

and make sure it's set to 'Automatic', which should then enable your handset to detect a local Airtime Provider. Once that is done, restart your handset, and it should connect to the local network.
Message 5 of 10
by: suzyevs
on: 29/05/2015 | 18:44
Hello
Are you connected to a network.
Make sure your network carrier in your settings is set to auto. This will allow your phone to connect to foreign networks. Also disable data roaming and use wifi where possible. Data use abroad is very expensive.
Then restart your phone.
big"It Takes 2 To Tango"
Message 6 of 10
by: isabel1066
on: 29/05/2015 | 18:46
welcome is your network settings on auto.
Get a free giffgaff Sim
Message 7 of 10
by: lizzy7777
on: 29/05/2015 | 18:47
Has manually selecting a network worked? If not please let us know
L x
Message 8 of 10
by: nigelbrooks
on: 29/05/2015 | 18:52

@debcard

 

You need to 'manually' select a network.

 

For some reason phones do not always pick up Airtel-Vodafone which is by far and away the most reliable roaming connection on Guernsey.

Get a free giffgaff Sim
I donate 100% of my SIM activation payback to charity, please help me boost the donation
Message 9 of 10
by: allan1954
on: 29/05/2015 | 18:57
guernsey not in the eu or the uk.
Get a free giffgaff Sim
Message 10 of 10