Knowledge Base

Iphone 4 new settings

Started by: callie02
On: 25/12/2013 | 09:21
Replies: 17

by: callie02
on: 25/12/2013 | 09:21
Hi Merry Christmas to everyone!..

Got new unlocked iphone 4 for Christmas and my chip from my iphone 3 will not work?

I have done everything the other posts say and entered the correct settings, but when I reboot they disappear again?

Tried lots of times?

Please help

Iphone 4 on iOS 7.0.4 latest update

Message 1 of 18
by: natty88
on: 25/12/2013 | 09:23
Try downloadin the giff gaff app via wifi from google play m8 or the tweakker app
Get a free giffgaff Sim
Message 2 of 18
by: rebelyell
on: 25/12/2013 | 09:24
Once the settings are in press the home button (the round button at the bottom front of your phone). Now switch your phone off and back on again.

There's a handy guide here:
Message 3 of 18
by: dugblare
on: 25/12/2013 | 09:25

Hi there


Put the settings in manually.                                                                               

This method is valid for all versions of iOS including iOS7


Step 1: Firstly, check whether you have an old profile. Head to Settings > General > Profile. If you can't see "Profile" move on to step 2. If you can see an old giffgaff profile, tap it and press "Remove".


Step 2: Go back to Settings > General and press "Reset". Don't worry, this doesn't delete any of your personal belongings.


Step 3: Hit "Reset Network Settings" and follow through. Note that this will delete your WiFi passwords! You may need to enter your passcode, at which point your iPhone will reboot.


Step 4: Go back to Settings > General > "Mobile Data" or "Network" (depending on your iOS version). For IOS7 Go to Settings > Mobile


Step 5: Tap "Mobile Data Network". Now under "Mobile Data" enter:


Username - vertigo

Password - password (this should already be entered by default)

 Leave Visual Voicemail as it is.


Step 6 (Almost there): Scroll down. Under MMS enter:


Username – vertigo

Password – password (again, this is the default)


MMS Proxy:

MMS Max Message Size - 2097152

MMS UA Prof URL (just leave blank)

Do NOT press the " Reset Settings " button when you’ve done this.


Once the settings are in, turn your iphone off ( via the red slider ) till the screen is completely blank. Then reboot. If you do not see the apple logo, the settings will not stick.


Then, press “ Settings “…“ Messages “ and ensure that " MMS Messaging " button is set to ON.

In " settings " " messages " turn imessages on.

Please also ensure that the " Enable 3G " button and the " Mobile Data " button are set to ON. (Press Settings, then General, then Mobile Data, or for IOS 7 Press Settings, then Mobile)

Then " Settings " ... " Phone " .... And check " My Number " is correct

Go to " Settings " ... " Carrier " and change to O2-UK.



Message 4 of 18
by: rebelyell
on: 25/12/2013 | 09:27
If you continue having problems with your iPhone resetting the settings once you have inputted them this guide may help.

1) Make sure your phone is connected to a WiFi network

2) On Safari go to:

7) Press Install

8) Press Install Now

9) Press Done

10) Reboot your phone. You should now have the giffgaff internet settings installed. If you want to add the MMS settings you can add them in Settings>General>Network>Mobile/Cellular Data Network.
Message 5 of 18
by: w69d
on: 25/12/2013 | 09:38

Depending on your iPhone iOS version and international language ""British English"" Or ""English""

iOS 7
Settings~Mobile~Mobile Data Network
Settings~Cellular~Cellūlar Data Network

iOS 6
Settings~General~Mobile Data~Mobile Data Network
Settings~General~Cellūlar Data~Cellular Data Network

iOS 5
Settings~General~Network~Mobile Data~Mobile Data Network
Settings~General~Network~Cellular Data~Cellular Data Network

Now check your settings are the same as these ,these are latest APN Settings for the iPhone which are slightly different to the normal ones and are the same as the iPhone app recommends / uses Which you can also use to get the Internet settings (but you'll still need the mms settings added manually )

please can you first reset the network settings as this can solve many problems with no Internet or can't send picture messages

Settings ~ General ~ Reset ~ Reset Network Settings

(once pressed the iPhone should reboot by itself )

Once the iPhone has automatically restarted goto the apn settings page

•Usernamė =vertigo
•Password =password

MMS Settings

• Username =vertigo
•Password =password
•mms Prōxy =
•mms Max Message Size = 2097152
•mms ua Prof URL (just leave blank)


 Photo 2.jpg

After editing the settings just press the Home Button (don't press the reset tab) ,Now please reboot your iPhone

(((General info : The text to 2020 won't install the mms settings on an iPhone , but will only install the (--older unsigned-- ) Internet ones, which will have giffgaff instead of the new username of vertigo

MMS will NOT work unless 3G / mobile data  is ON

Lastly check that the MMS button in the Settings. (Settings~Messages) Make sure MMS Messaging is set to ON.

And remember that MMS / Picture Messages cost 16p (24p for none uk networks )and are not included in any Goodybag ( Mobile Data must be on to receive MMS messages)

Message 6 of 18
by: callie02
on: 25/12/2013 | 09:53
Thanks guys,

I have tried this but the settings won't stay!..

I have reset after pressing home button, I have then shut down and rebooted!... No good

Put the settings in again, pressed home button and done hard reboot, no settings stay??....

Works perfectly in my iphone 3?

Tried the links but no good?

Sorry to nag?
Message 7 of 18
by: natty88
on: 25/12/2013 | 09:58
Lookin like a faulty phone m8 if sim is workin in other phone ok
Get a free giffgaff Sim
Message 8 of 18
by: callie02
on: 25/12/2013 | 10:01
My dad's vodaphone sim works straight away, without altering the settings???
Message 9 of 18
by: w69d
on: 25/12/2013 | 10:20
Which reset Tab are you pressing (not the one under the APN settings as that would just reset them again to )
Message 10 of 18