Knowledge Base

Iphone internet

Started by: thugpaki7861
On: 08/12/2011 | 04:00
Replies: 3

by: thugpaki7861
on: 08/12/2011 | 04:00
I cant access my giffgaff internet by using the iphone
Message 1 of 4
by: xtreemneo
on: 08/12/2011 | 04:04 edited: 08/12/2011 | 04:05

Hello thugpaki7861,


Your post is little ambigious. Smiley Indifferent  no worries Smiley Happy If you are referring to 3G internet, then please find the following.


Go to Settings>General>Network> Cellular Data Network


I guess you might have something related with o2, delete the ones and add the following.


Internet Settings



Username - giffgaff

Password - password

MMS Settings


Username - giffgaff

Password - password


MMS Proxy -

Max message size - 307200

MMS UA Prof URL - [blank]



That should take care of it, 

GiffGaff does not offer automatic settings for iPhone at the moment.. May be in the near future. 

Message 2 of 4
by: djbonner07
on: 08/12/2011 | 04:12

Make sure you have credit or a active goodybag then please follow this guide

Iphone Internet Settings

On your iPhone go to: Settings>General>Network>Cellular Data Network
Then enter:

Cellular Data

Username: giffgaff
Password: password

Visual Voicemail

leave blank as giffgaff do not provide it

Username: giffgaff
Password: password
MMS proxy:
MMS Max Message Size: 307200
MMS UA Prof URL: leave blank
restart the iPhone to activate the settings

If you get stuck check this guide > ( Video Guide >> )

                                                                        Easy Option For WiFi

1) Insert your giffgaff SIM
2) connect to wifi
3) open safari and go to (might take a while too load so just let it do it's thing)

4) a notification comes up and asks you to accept a profile

5) press install and then Install now to confirm

Get a free giffgaff Sim
Message 3 of 4