Get Help
Community

My mobile data has stopped working!

Started by: lordarmstrong
On: 03/04/2013 | 23:10
Replies: 11
Reply

by: lordarmstrong
on: 03/04/2013 | 23:10

Help me please, I've run out of ideas!

 

I can't receive data over the mobile phone network in any application. I've tried Facebook, Google and loads of others, they all say 'no data network connection'. Everything works fine when I'm connected via WiFi, it's just the mobile data that's the problem.

 

My APN settings are all correct (as shown at http://community.giffgaff.com/t5/giffgaff-Top-Tips/Definitive-APN-Settings-list/td-p/1279) and I can still send and receive phone calls, messages and picture messages.

I've not had an email saying I'm blocked and there's no service outage because my wifi dongle is still working.

I have 945Mb data left of a 1Gb allowance.

 

I'm using a Sony Xperia Z with the latest versions of Android, and I've 'hard reset' the thing.

 

Any ideas? Please help!

Message 1 of 12
by: krunchynut
on: 03/04/2013 | 23:10

giffgaff coverage

http://community.giffgaff.com/t5/Help-Ask-the-community-got-stuck/How-do-I-check-coverage/ta-p/34877...

Your signal might be poor or maintenance checks might be being carried out in your area..check out your area via this link above..

Get a free giffgaff Sim
Message 2 of 12
by: krunchynut
on: 03/04/2013 | 23:11

Switch your phone off, then take battery out, then reboot your phone install all the settings and it should work

 

Android
http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/Guide-Android-Phones/ta-p/3521671

 

Get a free giffgaff Sim
Message 3 of 12
by: paultheball
on: 03/04/2013 | 23:17
Use this lordarmstrong ...

SONY Xperia Z Internet and MMS settings guide..
Go to > Settings > More > Mobile Networks > Access Point Names > Tap on the existing o2 APN and now edit this APN with the giffgaff settings below, leave the name as it is (o2 payandgo)

Name - o2 Pay&Go then edit the rest to...
APN - giffgaff.com
Username - giffgaff
Password - password
MMSC - http://mmsc.mediamessaging.co.uk:8002
MMS Proxy -193.113.200.195
MMS Port - 8080
MCC - 234
MNC - 10

Now click the right hand key and choose Save.
Restart your mobile and you should be connected.

Get a free giffgaff Sim
Message 4 of 12
by: robasto
on: 03/04/2013 | 23:17

Is data enabled on your phone?

Get a free giffgaff Sim
Message 5 of 12
by: amirul16
on: 03/04/2013 | 23:18

ensure that your settings are correct and that you tarriff has not ran ou, any problems contact an agent

Get a free Giffgaff Sim
Message 6 of 12
by: tobi_onalaja
on: 03/04/2013 | 23:20
I've had the same problem on my blackberry in the past. Report the issue to an agent. They should be able to fix it soon enough.
If I have helped you please KUDOS me and accept as solution if I have solved your problem/query Smiley Happy Thanks
Message 7 of 12
by: darkthc76
on: 03/04/2013 | 23:39
I'm sorry I thought when you bought a goody bag it was unlimited so it sounds like you haven't activated the Giffgaff settings in your phone it seems that your data is still on O2 tariff were you only get 1gig a month (Giffgaff has to be the best choice for data) goodybags with data for £12.00, or £15.00 for unlimited data BARGIN.
Please press kudo if this helps
Message 8 of 12
by: lordarmstrong
on: 03/04/2013 | 23:46

Thanks very much, but those are the very same settings I already had.

I've double checked them and rebooted - still no joy.

Thanks for trying though.

Message 9 of 12
by: lordarmstrong
on: 03/04/2013 | 23:48

Thanks very much but I've tried that all with the exception of removing the battery, which isn't removable on the Xperia Z. Thanks for trying though, appreciated.

Message 10 of 12