Knowledge Base
Community

Number transfer sucessful but imsgs keep going to old iphone.

Started by: pin1972
On: 23/12/2017 | 09:57
Replies: 7
Reply

Go to best answer
by: pin1972
on: 23/12/2017 | 09:57

Hi, just got number transfered to new iphone6s plus from giffgaff a week ago.

 

but people keep txting me on the old iphone. Its driving me insane. I even logged out ot my account on the old phone.

a friend told me, when i txt them they get a different number...but they dont have problem caliing my new phone on my ported number.

 

thanks

Message 1 of 8
1 BEST ANSWER

Accepted Solutions
Highlighted
by: abidaa1
on: 23/12/2017 | 12:12
@pin1972

Just follow the below step and your issue will be sorted:

1. Switched off Face Time (Setting ->FaceTime->FaceTime OFF)

2. Switched off iMessage (Setting -> Messages->iMessage OFF)

3. Switched on iMessage (The phone started "Verifying" the incorrect phone number, failed and set it to the correct ported number (see Settings -> Messages -> Receive at -> Phone).

4. At this point the "My Number"(Settings ->Phone -> My Number) had also updated.

5. Switch on Face Time (Same "Verifying" as with iMessage, may take a couple of attempts)

6. Power Cycle the 'phone and re-synced to update iTunes (Summary "Phone Number"field).
Message 8 of 8
by: he22ie
on: 23/12/2017 | 10:00

If you have a new iphone the tendency is to set up the phone and deal with the sim. Turn off itunes and imessage and reboot with the giffgaff sim in. The Apple account has to learn the new network as it 'remembers' the old one. Hopefully this problem should solve when you resync

Message 2 of 8
by: giffgaffprepper
on: 23/12/2017 | 10:06
you need to reset network settings for transferred number to be recognised, this is a problem with iphones not gg

go to network settings , remove gg as network, then restart phone
Message 3 of 8
by: rebelyell
on: 23/12/2017 | 10:09
The wrong number showing is a common issue with iphones after a number transfer.

To fix the problem:

Go to Settings
Go to Messages
Switch iMessage OFF
Once it's switched off, turn it back ON again
Wait for it to finish activating iMessage
Once it's done, switch your phone off and back on again.
Message 4 of 8
by: stephenpperry
on: 23/12/2017 | 11:07

Hello! Sorry to hear about this! Believe me when I say you’re not alone!

 

apple created a tool to help you. 

 

If you go to this page... https://selfsolve.apple.com/deregister-imessage/ and scroll down there’s a field, put in your old mobile number and hit enter. It will deactivate your old number and stop iMessages going to it. 

Kudos costs me nothing, so I give it freely .

I started writing a blog on design, technology and the future Take a look and let me know what you think!
Message 5 of 8
by: lynda1962
on: 23/12/2017 | 11:20

@pin1972, hi there,  try 👇 

 

1. Go to Settings,
2. Go to Messages,
3. Switch iMessage OFF,
4. turn it back ON again,
5. Wait for it to finish activating iMessage,
6. Once it's done, reboot your phone.

 

Your messages should now display the right number

 


Message 6 of 8
by: kiyara2017
on: 23/12/2017 | 12:07

@pin1972

 

Go to Settings
Go to Messages
Switch iMessage OFF
Once it's switched off, turn it back ON again
Wait for it to finish activating iMessage
Once it's done, switch your phone off and back on again.

Message 7 of 8
Highlighted
by: abidaa1
on: 23/12/2017 | 12:12
@pin1972

Just follow the below step and your issue will be sorted:

1. Switched off Face Time (Setting ->FaceTime->FaceTime OFF)

2. Switched off iMessage (Setting -> Messages->iMessage OFF)

3. Switched on iMessage (The phone started "Verifying" the incorrect phone number, failed and set it to the correct ported number (see Settings -> Messages -> Receive at -> Phone).

4. At this point the "My Number"(Settings ->Phone -> My Number) had also updated.

5. Switch on Face Time (Same "Verifying" as with iMessage, may take a couple of attempts)

6. Power Cycle the 'phone and re-synced to update iTunes (Summary "Phone Number"field).
Message 8 of 8