Knowledge Base
Community

Phone not working in USA!

Started by: mpquina
On: 10/11/2013 | 22:24
Replies: 11
Reply

Go to best answer
by: mpquina
on: 10/11/2013 | 22:24
Hey
I'm in NYC with a friend and are both giffgaff users. He has an iPhone 5 and mine is a 4, and neither are working (no phone calls, texts, roaming).
Any thoughts!?
Thanks a lot
Message 1 of 12
1 BEST ANSWER

Accepted Solutions
Highlighted
by: kylie_ysyeng19
on: 10/11/2013 | 22:29

If you have sufficient credit, try manually roaming with one of giffgaff's American partners-AT&T or T-mobile

 

Generic Settings Guide

1. Go to settings
2. Then go to mobile networks
3. Select a network other than
O2(gg) i.e orange or tmobile
4. Come out of settings and it
should say no network coverage
or something
5. Repeat the process this time
choose O2(gg)
and this will update your
number to the message centre
and should help your txts

 

The message centre number in your message settings should be +447802002606

 

iPhone Settings

 

 

1. Go to settings

2.Go to carriers

image 3.png

 

 

3. Switch off automatic and manually change the carrier to something other then O2-UK i.e vodafone or orange

 

 

image 1.png

 

 

image.png

 

4. Come out of settings and wait until it fails to connect to the other carrier

5. Once it fails repeat the process and this time choose O2-UK

 

And a special thank you to fellow giffgaffer shortylumber for providing the scrscreenshots for the iPhone settings and for resizing my pictures on the Windows settings, thanks mate :heart:

 

 

The next part of the guide is for Android and BlackBerry and the research was done by fellow giffgaffer paultheball thanks mate. :heart:

 

Android Settings

 

1. Go to settings

Manual Roam Screenshots 1.png

 

 

2. Go to wireless & networks 

Manual Roam Screenshots 2.png

If you see the screen above then click 'more settings'

 

3.Go To mobile network

 

 Manual Roam Screenshots 3.png

 

 

4. Go to network operators 

Manual Roam Screenshots 4.png

 

You may at this point see this message 'unable to search networks while you're data service is active. Do you want to disconnect the data servive and search the available networks? ' just click OK

 

 

5. Search networks

 

Manual Roam Screenshots 5.png

 

 

6. A list of networks will soon display as you can see above

7. Select another network other then O2 i.e orange or tmobile

8. Wait until it fails to connect 

9. Repeat the process and this time choose O2

 

BlackBerry Settings

 

1. Click manage connection 

Bb manual roam 1.jpeg

 

2. Open mobile network option

Bb manual roam 2.jpeg

3. Select network selection and then change it from automatic mode to manual

Bb manual roam 3.jpeg

 

Bb manual roam 3 part 2.jpeg

 

4. Choose any other network other than O2 i.e orange or tmobile

Bb manual roam 4 part 1.jpeg

5. Leave the phone for 2/3 minutes 

6. Re-select the automatic mode and it will automatically return to O2

Bb manual roam 4 part 4.jpeg

 

Bb manual roam 4 part 4.jpeg

 

Bb manual roam 4 part 5.jpeg

7. Now reboot your phone

 

And a special thank you to fellow giffgaffer Woodyuk for taking the screenshots for me thanks mate. :heart:

 

 

Windows Settings

 


1. Go to settings.

Settings.png

 

 

2. Go to mobile network.

Mobile Network.png

 

 

3. In the 'data roaming options' box click it and select roam.

4. In the box under data roaming there is another box 'network selection' click it and click 'press to select' and a list of networks will appear.

 

Roam & Network.png                                        

 

5. Select another network other than O2 i.e Orange or Vodafone.

 

Select Network.png

 

6. Once it fails to connect to the other network just repeat the process and this time choose O2.

 

All credit to jokeyboi77

 

Have a great time in the States =)

 

Get a free giffgaff Sim
Message 5 of 12
by: sbibi21
on: 10/11/2013 | 22:26
Are you sure you have credit. Roaming needs credit not a goodubag
PLEASE GIVE KUDOS IF YOU FOUND THIS HELPFULL!!

THANK YOU!!!

Get a free giffgaff Sim
Message 2 of 12
by: djbonner07
on: 10/11/2013 | 22:26

[ giffgaff roaming information ]

• 1, Neither goodybags or gigabags will work once your out of the UK .. The goodybags and the gigabags only work in the UK so you will need to top-up and select normal top-up credit (airtime balance)



• 2, Full listings and all information is found here - www.giffgaff.com/index/international



• 3, More updates on new pricing http://community.giffgaff.com/t5/Blog/New-International-Pricing-and-EU-Roaming-Changes/ba-p/9057012



• 4, Auto Roaming is set as default so its set to work automatically


You might have to take your sim out for a minute or 2 and then put the sim back in and let it search for a network if you have any problems via connecting to a network or you carnt call out etc but please do make sure you have normal topup credit



• Network Problems? - http://is.gd/manualroam

Also-

• [ On Holiday No Network ]http://travelabroad.o2 uktech.com/coverage.php
Get a free giffgaff Sim
Message 3 of 12
by: skyline007
on: 10/11/2013 | 22:27
Try rebooting the phones
Get a free giffgaff Sim

Message 4 of 12
Highlighted
by: kylie_ysyeng19
on: 10/11/2013 | 22:29

If you have sufficient credit, try manually roaming with one of giffgaff's American partners-AT&T or T-mobile

 

Generic Settings Guide

1. Go to settings
2. Then go to mobile networks
3. Select a network other than
O2(gg) i.e orange or tmobile
4. Come out of settings and it
should say no network coverage
or something
5. Repeat the process this time
choose O2(gg)
and this will update your
number to the message centre
and should help your txts

 

The message centre number in your message settings should be +447802002606

 

iPhone Settings

 

 

1. Go to settings

2.Go to carriers

image 3.png

 

 

3. Switch off automatic and manually change the carrier to something other then O2-UK i.e vodafone or orange

 

 

image 1.png

 

 

image.png

 

4. Come out of settings and wait until it fails to connect to the other carrier

5. Once it fails repeat the process and this time choose O2-UK

 

And a special thank you to fellow giffgaffer shortylumber for providing the scrscreenshots for the iPhone settings and for resizing my pictures on the Windows settings, thanks mate :heart:

 

 

The next part of the guide is for Android and BlackBerry and the research was done by fellow giffgaffer paultheball thanks mate. :heart:

 

Android Settings

 

1. Go to settings

Manual Roam Screenshots 1.png

 

 

2. Go to wireless & networks 

Manual Roam Screenshots 2.png

If you see the screen above then click 'more settings'

 

3.Go To mobile network

 

 Manual Roam Screenshots 3.png

 

 

4. Go to network operators 

Manual Roam Screenshots 4.png

 

You may at this point see this message 'unable to search networks while you're data service is active. Do you want to disconnect the data servive and search the available networks? ' just click OK

 

 

5. Search networks

 

Manual Roam Screenshots 5.png

 

 

6. A list of networks will soon display as you can see above

7. Select another network other then O2 i.e orange or tmobile

8. Wait until it fails to connect 

9. Repeat the process and this time choose O2

 

BlackBerry Settings

 

1. Click manage connection 

Bb manual roam 1.jpeg

 

2. Open mobile network option

Bb manual roam 2.jpeg

3. Select network selection and then change it from automatic mode to manual

Bb manual roam 3.jpeg

 

Bb manual roam 3 part 2.jpeg

 

4. Choose any other network other than O2 i.e orange or tmobile

Bb manual roam 4 part 1.jpeg

5. Leave the phone for 2/3 minutes 

6. Re-select the automatic mode and it will automatically return to O2

Bb manual roam 4 part 4.jpeg

 

Bb manual roam 4 part 4.jpeg

 

Bb manual roam 4 part 5.jpeg

7. Now reboot your phone

 

And a special thank you to fellow giffgaffer Woodyuk for taking the screenshots for me thanks mate. :heart:

 

 

Windows Settings

 


1. Go to settings.

Settings.png

 

 

2. Go to mobile network.

Mobile Network.png

 

 

3. In the 'data roaming options' box click it and select roam.

4. In the box under data roaming there is another box 'network selection' click it and click 'press to select' and a list of networks will appear.

 

Roam & Network.png                                        

 

5. Select another network other than O2 i.e Orange or Vodafone.

 

Select Network.png

 

6. Once it fails to connect to the other network just repeat the process and this time choose O2.

 

All credit to jokeyboi77

 

Have a great time in the States =)

 

Get a free giffgaff Sim
Message 5 of 12
by: hobson2000
on: 10/11/2013 | 22:33
You will need to check that you both have plenty of credit due to roaming charges, that is charges whilst outside of uk.

If you have then you will need to manually search for network provider either AT&T ot T-Mobile

Go into settings

Then carrier

the phone will list carriers available

select either of above

hope this helps

Phil
Get a free giffgaff Sim
Message 6 of 12
by: kevgaxx
on: 10/11/2013 | 22:37
I hope you've got credit. Goodybags don't work when abroad.
It's very expensive in the USA and there are no roaming packages either. Be careful with your phone use.
Anyway, the o2/giffgaff partner networks are AT&T and T-Mobile, so make sure you are connected to one of them ( should be automatic, but check ). Manually find either network if you have to.

Making calls £1/min
Receiving calls £1/min
Sending text 30p
Receiving texts is free
MMS to UK mobile 16p
MMS to foreign mobile 24p
Data £5/MB *
* Monstrously expensive. It's better to disable data roaming. Use free wifi where possible, or get a local SIM.

http://giffgaff.com/index/international
Message 7 of 12
by: zcbmm
on: 10/11/2013 | 22:46
Manual connect to att or tmobile?
Get a free giffgaff Sim
Message 8 of 12
by: janbenedykt
on: 06/05/2015 | 15:02
I am in New York and having the same problem but this is not a credit problem because I have used it in Brazil before with no problem.
Here,  there is no signal on the phone and no network found when I try to manually connect.
Any ideas anyone?
Message 9 of 12
by: thundercliffcottage
on: 06/05/2015 | 15:08

Hi, Try  and see if you can get a local PAYG Sim and use that while you are in the USA.

Get a free giffgaff Sim
Message 10 of 12