Get Help
Community

Phone showing wrong number on texts

Started by: robcherry
On: 08/02/2014 | 08:26
Replies: 6
Reply

Go to best answer
by: robcherry
on: 08/02/2014 | 08:26
Hi, I have imported my old O2 contract number on to giffgaff. It's gone through ok but when I text people it comes through with the original giffgaff number on their phone. Any ideas?
I know the port went through ok as I do receive calls and texts off people who only know the number I ported in!!!!!
Help gratefully received
Rob
Message 1 of 7
1 BEST ANSWER

Accepted Solutions
by: essie112mm
on: 08/02/2014 | 08:30
Best Answer

Hi Rob,

 

This is a common problem with iPhones after a number has been transferred

 

Try this procedure to correct the problem

1. Settings >> FaceTime > FaceTime > OFF
2. Settings > Messages > iMessage > OFF
3. Settings > Messages > iMessage > ON

Your phone should now check and set up your transferred number so verify this has happened here

Settings > Messages > Receive At > Phone
Settings > Phone > My Number

4. Settings > Facetime > Facetime > ON

Lastly, reboot the phone and also re sync it  to iTunes

In theory, your texts should now show the correct number 

27/08/2017
My @mentions are turned OFF
Message 4 of 7
by: bruno00
on: 08/02/2014 | 08:29
Go to Settings
Go to Messages
Switch iMessage off
Switch iPhone off
Connect to iTunes via USB (iPhone will switch back on)
Allow iTunes to check for updates (may not find any)
Sync iPhone with iTunes
Switch iMessage back on and allow to fully initialise
Once it's done, restart your phone


You can check that your phone has your right number in Settings > Phone > My Number. Just type in your new number if it's not already shown.



Hope this helps.

Message 2 of 7
by: phil_72
on: 08/02/2014 | 08:30
Is it an iPhone? Go to settings, phone, and look at the number. What shows? If it's the giffgaff one, change it to yours. Then, restart iMessage.
Get a free giffgaff Sim
Message 3 of 7
by: essie112mm
on: 08/02/2014 | 08:30
Best Answer

Hi Rob,

 

This is a common problem with iPhones after a number has been transferred

 

Try this procedure to correct the problem

1. Settings >> FaceTime > FaceTime > OFF
2. Settings > Messages > iMessage > OFF
3. Settings > Messages > iMessage > ON

Your phone should now check and set up your transferred number so verify this has happened here

Settings > Messages > Receive At > Phone
Settings > Phone > My Number

4. Settings > Facetime > Facetime > ON

Lastly, reboot the phone and also re sync it  to iTunes

In theory, your texts should now show the correct number 

27/08/2017
My @mentions are turned OFF
Message 4 of 7
by: bengalknights
on: 08/02/2014 | 09:38
If your using a iphone switch off imessage and facetime then back on
Get a free giffgaff Sim
Message 5 of 7
by: jazmin69
on: 08/02/2014 | 09:58
I wish to god apple would fix this
Get a free giffgaff Sim
Message 6 of 7
by: scrappydez
on: 08/02/2014 | 10:51

@robcherry  Might be worth you checking out this thread on the upcoming settings change for iPhone users.

http://community.giffgaff.com/t5/News-Announcements/Settings-change-for-iPhone-users-10th-Feb-2014/m...

Get your SIM delivered today by 1st Class Post, yeah boy.
Message 7 of 7