Knowledge Base
Community

Sim not working having been ok for 2 months

Started by: marcusx19
On: 15/10/2010 | 10:36
Replies: 3
Reply

by: marcusx19
on: 15/10/2010 | 10:36

Hi community, Having been with giffgaff for a couple of months with no problem I removed and replaced my giffgaff sim and now it doesn't work! the phone starts up ok but it doesn't register the sim, anyone know why this may be, I have taken it out and tried it several time but no joy. If I go to select a network Giffgaff doesn't appear in the choices. Please help if you can. Thanks, Marcus

Message 1 of 4
by: dik
on: 15/10/2010 | 10:43

 


@marcusx19 wrote:

Hi community, Having been with giffgaff for a couple of months with no problem I removed and replaced my giffgaff sim and now it doesn't work! the phone starts up ok but it doesn't register the sim, anyone know why this may be, I have taken it out and tried it several time but no joy. If I go to select a network Giffgaff doesn't appear in the choices. Please help if you can. Thanks, Marcus


Hi, is it possible to try your sim in another phone or another sim in your phone? this would narrow source of problem..dik

 

Message 2 of 4
by: spartacus
on: 15/10/2010 | 10:46

Seems a bit odd - tried all the obvious I presume -

SIM is in the right way
Brushed any dust away
Try another SIM in the same phone etc etc
Get a free Giffgaff Sim
Message 3 of 4
by: rjheald
on: 15/10/2010 | 13:10

giffgaff may not appear in the network choices, just select O2 for the network

For a free sim with £5 credit click here
To switch signatures off go to My Community Settings>Preferences and remove the tick from View signatures in posts.
Message 4 of 4