Knowledge Base
Community

Simcard works in Sony Erric phone but not in iPhone 'Activation Required'

Started by: timetosurf
On: 23/11/2011 | 12:55
Replies: 4
Reply

Go to best answer
by: timetosurf
on: 23/11/2011 | 12:55

Hi,

 

I have a giff gaff simcard  that works perfectly well in a Sony Err. phone however every time i place it in a iPhone 3GS it keeps reporting 'Activation Required'. The sim was activated many days ago and works well in my Sony phone, anybody any ideas.

 

Regards

 

Ravi

Message 1 of 5
1 BEST ANSWER

Accepted Solutions
Highlighted
by: kyle009
on: 23/11/2011 | 13:39
Sounds like you need to connect your phone to iTunes so it can activate the sim card in it.

I've had to do this when changing sims on my 3GS.
Message 5 of 5
by: alant
on: 23/11/2011 | 13:00

@timetosurf wrote:

Hi,

 

I have a giff gaff simcard  that works perfectly well in a Sony Err. phone however every time i place it in a iPhone 3GS it keeps reporting 'Activation Required'. The sim was activated many days ago and works well in my Sony phone, anybody any ideas.

 

Regards

 

Ravi



Have a look here http://www.techiechips.com/activate-iphone-3g/  not sure whether it will help, but might be worth a look.

Get a free giffgaff Sim
Message 2 of 5
by: mickf
on: 23/11/2011 | 13:30

Have you put the giffgaff settings into your iphone?

Message 3 of 5
by: slamboom
on: 23/11/2011 | 13:38 edited: 23/11/2011 | 13:39

maybe you need to activate the phone in itunes.

Get a free giffgaff Sim
Message 4 of 5
Highlighted
by: kyle009
on: 23/11/2011 | 13:39
Sounds like you need to connect your phone to iTunes so it can activate the sim card in it.

I've had to do this when changing sims on my 3GS.
Message 5 of 5