Knowledge Base
Community

Terrible data service in Pimlico area of London (SW1V)

Started by: foonle
On: 11/10/2013 | 10:52
Replies: 7
Reply

Go to best answer
by: foonle
on: 11/10/2013 | 10:52

I usually have a great data service but since yesterday it has been terrible. I can't do anything that requires data (web, email etc). It's not a phone issue. I occasionally get a few mins of data then in stops again. My iPhone 4S is showing a full 3G signal and like I said, I usually have fast data in this area. 

 

Does anyone have a similar issue? How do I go about sorting this out? Thanks

 

Message 1 of 8
1 BEST ANSWER

Accepted Solutions
by: lucy68
on: 11/10/2013 | 10:54

check your area status here: http://bit.ly/o2status

for text /calls/data problems please see here: http://is.gd/manualroam

Get a free giffgaff Sim
Message 3 of 8
by: sick_p
on: 11/10/2013 | 10:53
Reboot your phone
Don't forget to Kudo me if I've been helpful and mark as solution where appropriate :-)
Message 2 of 8
by: lucy68
on: 11/10/2013 | 10:54

check your area status here: http://bit.ly/o2status

for text /calls/data problems please see here: http://is.gd/manualroam

Get a free giffgaff Sim
Message 3 of 8
by: olamide_a
on: 11/10/2013 | 10:56
Firstly check the signal in your area to look for any faults
with the network. You can do so by visiting this website
www.bit.ly/ggservicestatus

If everything is okay with the signal in your area then you
should try a manual roam which will update your connection
with the network. Click on this link to view how to do a
manual roam http://is.gd/manualroam
Message 4 of 8
by: clare201012
on: 11/10/2013 | 10:57
Signal checker

Check the signal in your area to look for any faults with the network. Please type your postcode in here : www.bit.ly/ggservicestatus

If the signal in your area is working as normal,
please try a manual roam to update your connection with the network. This can often help fix these type of communication problems : http://is.gd/manualroam

Have a good day :-)
Message 5 of 8
by: foonle
on: 11/10/2013 | 10:57 edited: 11/10/2013 | 10:58

Already tried rebooting, will check signal now...

Message 6 of 8
Highlighted
by: foonle
on: 11/10/2013 | 11:01

I check the area status and is looks like there is a problem. It's been 2 days now, does anyone know how long these things take to fix?

 

 

  • Sorry we're currently investigating reports that a phone mast in this area isn't working.
    This means you might experience problems making calls, using the internet, or sending / receiving emails in this area.
    Updated 10:00 (refreshed hourly). Recent faults might not show yet.

 

 
  • Normal coverage for Voice, text and email (2G)
    Making calls, sending texts, using email on your phone.
    Good indoors and outdoors.
  • Normal coverage for Mobile internet and voice (3G)
    Fast networking. For smartphones, dongles and tablets.
    Good indoors and outdoors. Good for mobile broadband.
  • Normal coverage for Mobile Internet (4G)
    Seamless connectivity and mobile internet.
    Good indoors and outdoors. Good for mobile broadband.
Message 7 of 8
by: djmarksel
on: 11/10/2013 | 11:04
check area status here http://bit.ly/o2status
could be some O2 maintenance
Solved! Go to Solution. Please give me Kudos if I have helped you out


Message 8 of 8