Get Help
Community

Texts Not Sending On Samsung Galaxy S3!

Started by: qibu_7
On: 17/06/2013 | 09:30
Replies: 6
Reply

Go to solution
by: qibu_7
on: 17/06/2013 | 09:30
Hello everyone, everytime I try to send a text my phone keeps saying that the message is sending and it keeps pending even though I have an active Goodybag with Unlimited Texts... Can someone please help me? Thanks!
Message 1 of 7 (14,869 Views)
1 ACCEPTED SOLUTION

Accepted Solutions
by: endorphin
on: 17/06/2013 | 09:34
Best Answer
Accepted by will23 (former giff-staffer)
‎21-08-2015 01:01
Check to see if there are any outages in the mobile network where you are: http://community.giffgaff.com/t5/Service-Updates-Notice-board/Find-out-the-service-status-of-your-ar...

If OK then see if doing a manual roam helps http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/manual-roam/m-p/3345471#M32502

Also try turning airplane mode on and then back off.

If no joy then try turning your phone off and back on.

Get a free giffgaff SIM/microSIM/nanoSIM with free £5 credit
Message 3 of 7 (16,320 Views)
by: dieter1
on: 17/06/2013 | 09:31

check your local area coverage on the o2 site,

 

also remove all settings then re input them 

If I have helped please KUDOS me to the left and accept as solution if I have solved your problem/query
Get a free giffgaff Sim
Message 2 of 7 (14,862 Views)
by: endorphin
on: 17/06/2013 | 09:34
Best Answer
Accepted by will23 (former giff-staffer)
‎21-08-2015 01:01
Check to see if there are any outages in the mobile network where you are: http://community.giffgaff.com/t5/Service-Updates-Notice-board/Find-out-the-service-status-of-your-ar...

If OK then see if doing a manual roam helps http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/manual-roam/m-p/3345471#M32502

Also try turning airplane mode on and then back off.

If no joy then try turning your phone off and back on.

Get a free giffgaff SIM/microSIM/nanoSIM with free £5 credit
Message 3 of 7 (16,321 Views)
by: figment_uk
on: 17/06/2013 | 09:35
Are you trying to send to standard UK mobile numbers? The unlimited text in goodybags do not work for international, premium rate or short code text numbers.
Message 4 of 7 (14,851 Views)
by: gaznicki
on: 17/06/2013 | 09:37
You may need to check the service in your area. Do this here: http://giff.ly/ggservice

You should also do a manual roam. Go to settings and change your service provider to manual, then choose a network other than O2/giffgaff. After a few moments, change back to O2/giffgaff.

Also, have you tried a re-boot of the phone. Simply turn the phone off and pull the battery for 60 seconds then re-boot. This can fix all manner of problems.
Message 5 of 7 (14,848 Views)
by: kelly290879
on: 17/06/2013 | 09:39
Restart the handset (hold down power button then select restart) then check, if it still does not follow these steps :

Go to "Settings" and then "Wireless & networks"
Go to "Mobile networks" and then to "Network operators"
Search for networks
Select a network other then o2
Wait until it fails to connect
Repeat the process but select o2 as your network
Get a free giffgaff Sim
Message 6 of 7 (14,845 Views)
by: yazogurbuz
on: 17/06/2013 | 09:47
hey please see -

You are having problems with sending or receiving SMS/texts then this trick might resolve the problem.

1. Go to settings 2. Then go to mobile networks 3. Select a network other than O2 (gg) i.e orange or tmobile. 4. Come out of settings and it should say no network coverage or something similar. 5. Repeat the process this time choosing O2 (gg) which should update the message centre and hopefully restart the texts.

The message centre number in your message settings should be +447802002606


If you think my post helped you even 1% Smiley Happy please click the ** KUDO STAR** !!!
If your query is solved with my inputs please click "ACCEPT A SOLUTION" !!!


Click here to request a giffgaff SIM or microSIM with £5 credit
Message 7 of 7 (14,842 Views)