Get Help
Community

Yet another tethering thread

Started by: issei
On: 23/04/2012 | 12:56
Replies: 8
Reply

Go to best answer
by: issei
on: 23/04/2012 | 12:56

Can anyone help me get tethering working with a gigabag on giffgaff?  My setup is slightly unusual - I'm tethering over bluetooth from Linux running network manager to a Nokia E61 running S60 3rd edition.  For comparison, I've been able to tether from the same machine to a Nokia N97mini running S60 5th edition using a different network operator's SIM.

 

The behaviour I observe with giffgaff is that a bluetooth connection is established and a connection opens up called 'modem' which then fails to connect.  I have configured the E71 to use the Giffgaff WAP access point (Settings->Connection->Packet Data->Access Point).  I've also configured network manager to use the Giffgaff WAP access point in its settings.

 

For comparison, with my N97mini I also see a connection called 'modem' being established, but this connects fine and I'm using it currently.

 

Normal data access on the phone works fine.  I select the Giffgaff WAP access point, and it opens a connection under that name (rather than 'modem').

 

Does anyone know why the connection isn't working?  Is it being blocked because I've got some settings wrong?

Message 1 of 9
1 BEST ANSWER

Accepted Solutions
by: jtemplar
on: 23/04/2012 | 13:16
Best Answer

I'm no Linux expert but these posts may have some clues for you including installing a Bluetooth app to replace Linux' own BT applet:

 

http://www.thinkwiki.org/wiki/Installing_Fedora_7_on_a_ThinkPad_T60#Bluetooth

http://www.webupd8.org/2010/02/iphone-usb-bluetooth-tethering-with.html

 

giffgaff settings:

APN: giffgaff.com

user name: giffgaff

password: password

number to dial: *99#

 

Message 5 of 9
by: giffgafful
on: 23/04/2012 | 12:58 edited: 23/04/2012 | 13:08

The settings in case they are the problem:

 

APN: giffgaff.com

user name: giffgaff

password: password

number to dial: *99#

 

You may also want to try to disable the PIN on your SIM. I had to do that to get my dongle connection to work under Ubuntu.

Message 2 of 9
by: ljk876
on: 23/04/2012 | 13:06
input da settings and den restart da fone
Get a free giffgaff Sim
Message 3 of 9
by: hoonboof
on: 23/04/2012 | 13:11 edited: 23/04/2012 | 13:13

Can you post the contents of /etc/bluetooth/rfcomm.conf 

[edit] or the equivalent under whatever distro you use

[edit2] just so you know, i do not generally use NetworkManager either, so I won't be able to determine if it's interfering

GiffGaff Referral
Message 4 of 9
by: jtemplar
on: 23/04/2012 | 13:16
Best Answer

I'm no Linux expert but these posts may have some clues for you including installing a Bluetooth app to replace Linux' own BT applet:

 

http://www.thinkwiki.org/wiki/Installing_Fedora_7_on_a_ThinkPad_T60#Bluetooth

http://www.webupd8.org/2010/02/iphone-usb-bluetooth-tethering-with.html

 

giffgaff settings:

APN: giffgaff.com

user name: giffgaff

password: password

number to dial: *99#

 

Message 5 of 9
by: issei
on: 23/04/2012 | 13:22

I'm guessing I'm not using that file:

 

cat /etc/bluetooth/rfcomm.conf
#
# RFCOMM configuration file.
#

#rfcomm0 {
#    # Automatically bind the device at startup
#    bind no;
#
#    # Bluetooth address of the device
#    device 11:22:33:44:55:66;
#
#    # RFCOMM channel for the connection
#    channel    1;
#
#    # Description of the connection
#    comment "Example Bluetooth device";
#}

I am running Debian 6 with xfce4, which uses the Gnome Network Manager.  I configure the bluetooth connection using /usr/bin/bluetooth-preferences, which I think is a gnome thing.

Message 6 of 9
by: hoonboof
on: 23/04/2012 | 13:37 edited: 23/04/2012 | 13:38

Yeah it's like a Gnome thing and I'm not a Gnome guy. If you want to try set it up manually the fedora link posted above has basically everything you'll need to try it manually. Basically hcitool scan to get the MAC of your device, use sdptool browse to get the right channel for your modem and edit the info into rfcomm.conf, setup ppp (edit your equivalent of /etc/conf.d/net if debian daemonises it, i'm an arch/gentoo guy), restart bluez, bring interface up, test.

 

Te Fedora link above mentions Gnome so you might be able to get away with not farting about with ppp, then again NetworkManager probably does it all for you so I can't even be sure.

GiffGaff Referral
Message 7 of 9
by: issei
on: 23/04/2012 | 22:50
Thanks, your posting of the settings was all it took. I'd previously tried to connect using the APN 'giffgaff WAP' as that's the general purpose APN defined on my phone. But switching to using 'giffgaff.com' on the PC side (I left the phone settings alone) is enabling me to post this on my gigabag. Oddly enough, I didn't have anywhere to enter the username or password, but it still seems to have connected at 3G speeds.
Message 8 of 9
by: hoonboof
on: 24/04/2012 | 19:06

Glad you got it sorted pal!

GiffGaff Referral
Message 9 of 9