Knowledge Base

can't send texts on iPhone 5 after sim swap

Started by: sandman
On: 30/04/2015 | 00:18
Replies: 7

by: sandman
on: 30/04/2015 | 00:18

just inserted new sim in an iphone 5 and done a sim swap.  now calls are flaky and can't send texts....any ideas?

Message 1 of 8
by: flaxvert
on: 30/04/2015 | 00:22

Please try rebooting your device as this fixes many issues.


If that has not solved your issue then check if there is any network maintenance affecting your service by going to


Or on a mobile device check here

Image and video hosting by TinyPic src="" width="550" height="80" alt="Get a free giffgaff Sim" >
Message 2 of 8
by: pwincess2k13
on: 30/04/2015 | 00:23
Give it a bit more time. If it doesn't work to day contact an agent regarding sim swap. Explain it to them

contact an agent here
Get a free giffgaff Sim
Message 3 of 8
by: mathew40
on: 30/04/2015 | 00:23
Hi there @sandman
Please can you firstly click onto this link

If you could also try turning your device OFF and take your sim card out, then wait 5 minutes,and turn your device ON again,as this can help in most cases.
Also try turning your airplane mode ON and OFF again ,and if your issue has not been resolved,check the signal in your area,by visiting or clicking onto the link below.
Please be aware that the website is updated hourly, so there may be a current issue that's
not showing at the moment,so keep checking the signal checker website over the next few hours or so for any new updates.

See here

If the signal checker is showing NO reported issues,you could also perform a manual roam,which basically is searching for networks on your device.
Go to your phone's "settings" and Select mobile network options and Change the Network Selection Mode from Automatic to Manual, and list of available networks will be displayed after a few moments, ( be patient whilst your device starts searching for all the available networks) .
Once all the available networks are showing,
Select any other network that is not your own network,and After a few moments you will see "No Service" on the display.
Now select your home provider(which is O2/giffgaff) network and change the selection back to Automatic,and see if that helps.

Please also check out this great guide here
Get a free giffgaff Sim
Message 4 of 8
by: jeffpeps
on: 30/04/2015 | 00:24
Try turning iMessages off & back on again then reboot your phone see if that helps 🇬🇧
Message 5 of 8
by: sandman
on: 30/04/2015 | 01:09

still no good - but many tks for trying!

Message 6 of 8
by: sandman
on: 30/04/2015 | 20:08

had to factory reset iphone 5 then resync what i needed back onto phone.

works brilliantly now


tks for suggestions everyone!!!

Message 7 of 8
by: klccklcc
on: 30/04/2015 | 20:11
have you activate the sim? if so can take upto 24hr to activate
Get a free giffgaff Sim
Message 8 of 8