Knowledge Base

cant use mobile data

Started by: tanya123494
On: 31/05/2015 | 12:38
Replies: 5

by: tanya123494
on: 31/05/2015 | 12:38
Got a samsung s6 as soon as i turn off wifi its not lettin me use mobile data
Message 1 of 6
by: avid_fan
on: 31/05/2015 | 12:40

You probably need the giffgaff settings

If the giffgaff settings have not installed automatically this Android guide from the Knowledge Base will show you how to set up your mobile

Alternatively, please see this step by step guide to setting up your android mobile
Go to Settings then More Settings then Mobile Networks then Access Point Names. Press the Menu key (might be the touch button with three dots in the top right of the screen), then select + New APN

In the boxes, type the following details:

● Name: giffgaff
● APN:
● MMS proxy:
● MMS port: 8080

(don't alter any other settings in the APN list)
Now press the Menu button again and select Save.
Tap the circle next to the profile named giffgaff so that a green/blue dot appears. You should now be connected to giffgaff. If you have any problem, a quick restart of your mobile after installing the settings usually sorts it

Get a free giffgaff Sim
Message 2 of 6
by: bengalknights
on: 31/05/2015 | 12:42
For android settings do below or install giffgaff apn app from play using wifi

From the homescreen;
1.Tap the Menu button
2.Tap Settings
3.Tap Wireless and networks or More... (depending on your version of Android)
4.Tap Mobile Networks
5.Tap Access point names
6.Tap the Menu button
7.Tap New APN
8.Enter the following data into the onscreen form, without changing any other settings;

Name - giffgaff
Username - giffgaff
Password - (leave blank)
MMS Proxy -
MMS Port - 8080
APN type - If given a choice, select internet+mms, if the keyboard appears enter *

9.Tap the Menu button
10.Tap Save
11.Enable the newly-added APN by ensuring the line is ticked, or the radio button is lit by tapping on it
12.Check the notification bar for H, 3G, E or G with up and down arrows beside it, which will indicate your connection is working
Get a free giffgaff Sim
Message 3 of 6
by: w69d
on: 31/05/2015 | 12:43

Hi,have you tried the app's from the play store ? here's a few of the better ones


the APN APP by Paul Shirley , which can install the APN settings on older android devices or can guide you through the settings on later OS (4.2 & over


there's also this app by quetonix ( qasman )


But here's the offical my giffgaff app which can only show you the APN settings , plus the usual balance and goodybag allowances (& community forum ) 


If that doesn't work on your phone then

you could also seë if the standard android APN settings

can do the trick by adding them manually 


Go to Settings.

Choose More Settings.

Choose Mobile networks.

Choose Access Point Names.

Press the Menu (or the left physical ) button on your phone and choose New APN.


Tap Name and type giffgaff, then tap OK.

Tap APN and type then tap OK.

Tap MMSC and type 

Tap MMS proxy and type

Tap MMS port and type 8080



some devices using

4.2 & above 

may need any of the following fields


username: giffgaff


Bearer : Unspecified

MVNO type : IMSI

MVNO value : 23410x

APN protocol : IPv4

APN Roaming protocol : IPv4

Authentificationtype : PAP or  PAP or CHAP

APN Type : default,supl,mms

if the keyboard appears you can put in default,* instead


Make sure not to confuse "browser proxy" and "MMS proxy". The first one must be left [blank] and the value for MMS Proxy is


Now press the Menu button on your phone again, and choose Save


Tap the little circle to the side of the profile named giffgaff on the list. It should turn Green or Blue


Once you've restarted your phone then you should be set up for giffgaff's mobile data and MMS settings.


if for any reason you can't set the profile after editing then you should also try this guide on resetting the profiles to defaults ~here

Message 5 of 6