Get Help
Community

iMessage, WhatsApp not working on iPhone 4

Started by: mmejia
On: 11/09/2012 | 16:58
Replies: 11
Reply

Go to solution
by: mmejia
on: 11/09/2012 | 16:58

Hi guys, 

I've read your help comments about iMessage not working for newbies - I've tried all suggested solutions to no avail.

I can connect to twitter, facebook etc but somehow can't send iMessages or WhatsApp messages unless there's wifi... I used to be able to send them through 3G.

What am I missing?

 

 

Message 1 of 12 (2,993 Views)
1 ACCEPTED SOLUTION

Accepted Solutions
by: shabbako1
on: 11/09/2012 | 16:59
Best Answer
Accepted by topic author mmejia
‎21-08-2015 01:01
Fix iPhone internet problems - YouTube, Whatsapp, SkyGo, Uploading pictures etc.

http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/Fix-iPhone-internet-problems-YouTube-Whatsa...
FREE NORMAL SIM OR MICRO SIM WITH £5 FREE CREDIT CLICK ON THE BANNER
Get a free giffgaff Sim
Message 2 of 12 (3,236 Views)
by: shabbako1
on: 11/09/2012 | 16:59
Best Answer
Accepted by topic author mmejia
‎21-08-2015 01:01
Fix iPhone internet problems - YouTube, Whatsapp, SkyGo, Uploading pictures etc.

http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/Fix-iPhone-internet-problems-YouTube-Whatsa...
FREE NORMAL SIM OR MICRO SIM WITH £5 FREE CREDIT CLICK ON THE BANNER
Get a free giffgaff Sim
Message 2 of 12 (3,237 Views)
by: akmed786
on: 11/09/2012 | 17:00
Message 3 of 12 (2,981 Views)
by: hunter4564567
on: 11/09/2012 | 17:00
http://community.giffgaff.com/t5/Learn-
giffgaff-Top-Tips/Fix-iPhone-internet-problems-
YouTube-Whatsa...
see this mate
Get a free giffgaff Sim
Message 4 of 12 (2,980 Views)
by: lmills
on: 11/09/2012 | 17:00
Go to Settings General. Scroll down to Profile. If you have a profile remove it. Then enter you settings manally. In Settings General Network Mobile data network. 

Mobile data:
Apn : giffgaff.com
Username: giffgaff
Password: password

Visual voicemail. There are no settings for this so the voicemail button wont work - dial 443

MMS
Apn: giffgaff.com
Username: giffgaff
Password: password
MMSC: http://mmsc.mediamessaging.co.uk:8002
MMS Proxy: 193.113.200.195:8080
MMS max message size: 3072000
Mms ua prof url: leave blank

Dont press Reset Settings then restart your phone
Get a free Giffgaff Sim
Message 5 of 12 (2,979 Views)
by: falsetruth
on: 11/09/2012 | 17:00
First reboot holding the power and home button like 30 secs.And try.
If that dont work then go to Message settings on iPhone and turn off iMessage and turn it back on.
Get a free giffgaff Sim

Message 6 of 12 (2,978 Views)
by: nuv
on: 11/09/2012 | 17:33
Message 7 of 12 (2,964 Views)
by: edgy360
on: 11/09/2012 | 17:34

Does browsing normal pages in Safari work ok?

Message 8 of 12 (2,961 Views)
by: ihassan1
on: 11/09/2012 | 17:35
u need correct iphone apn settings for mss and data remove all default and use gg apn settings for iphone there is a guide on gg search for it!
If your happy with my post press**(the yellow kudos star to the left) or click accept as solution
Message 9 of 12 (2,959 Views)
by: g1x3r
on: 11/09/2012 | 17:45
First You should delete any profile with the Internet settings and then manually enter them.
I had this problem on a couple of iPhones and deleting the profile fixed it for me. Whatsapp is fine now.
Get a free giffgaff Sim
Message 10 of 12 (2,956 Views)