Get Help
Community

iMessage sending the wrong phone number....

Started by: rmhumfress
On: 19/10/2011 | 17:39
Replies: 9
Reply

Go to solution
by: rmhumfress
on: 19/10/2011 | 17:39

Having recently updated to IOS 5 on 3 iphone 4 phones, one phone (the one with the Giffgaff SIM in) is having a problem with iMessage. Texts sent from it are appearing to be sent from the SIM's original number, not the active phone number (ie one that has been PAC'd across).

 

Sending texts to the PAC'd number results it the text being sent via SMS.

 

Does anyone else have this problem? All other functionality is fine.  

 

Thanks

Roger.

Message 1 of 10 (13,232 Views)
1 ACCEPTED SOLUTION

Accepted Solutions
by: stephenmiller
on: 19/10/2011 | 17:40
Best Answer
Accepted by topic author rmhumfress
‎21-08-2015 01:01

What phone number do you have saved in your contacts under 'myself'

Message 2 of 10 (13,821 Views)
by: stephenmiller
on: 19/10/2011 | 17:40
Best Answer
Accepted by topic author rmhumfress
‎21-08-2015 01:01

What phone number do you have saved in your contacts under 'myself'

Message 2 of 10 (13,822 Views)
by: as7861
on: 19/10/2011 | 17:41

Can you go into Mygiffgaff and see if the numbers match ? 

- Amer Get a free giffgaff Sim
Message 3 of 10 (13,205 Views)
by: morvin
on: 19/10/2011 | 17:42
I don't have this problem. Contact an Agent http://bit.ly/giffgaffagent

I just went to settings> Messages> Turn iMessage ON. and it should use only one number which is your active number
Get a free Giffgaff Sim
Please give 'KUDOS' if you like my post. If my answer helped then please click 'Accept as Solution'
Message 4 of 10 (13,203 Views)
by: aksthehunk
on: 19/10/2011 | 17:43
Check the number that is being displayed as myself (SIM card own phoen number) under your contacts. Hope the dashboard is showing the correct number https://giffgaff.com/dashboard
Message 5 of 10 (13,199 Views)
by: rmhumfress
on: 19/10/2011 | 17:48

Thanks, 

 

Under General/Phone/My Number, it had the original SIM number. Changed that and everything straightened out.

 

Regards

Roger

Message 6 of 10 (13,192 Views)
by: leytonpage
on: 20/10/2011 | 23:39
I ported my number today and ended up with the same problem. Texts were coming from my old (ported) number, but I had used iMessage with my temporary number and messages sent through iMessage were appearing to be sent from that. Not sure how you change the number but I turnedas described above but I turned off iMessage in settings and turned it back on and now it is working.
Message 7 of 10 (13,070 Views)
by: uw_photographer
on: 22/10/2011 | 10:52

I also had a similar situation - you cant change the number in imessage settings, it has to be changed in phone settings (this is a global setting).

 

My wife had her iphone 4 on Voda and the "my number" still referred to that (when she sent me texts, it appeared to come from that number, even tho she is now on the O2 network). When I changed it, all was well, but it took a few minutes for the settings to take effect.

 

On my 3GS, my "own number" was correctly set, but in my contacts, I had a contact for myself and the number was listed as "mobile" rather than 'iphone". When I changed it to the latter, all was well with imessage (again, after a little wait- I initially did not think it had worked).

 

Hope these experiences help anyone else setting up the new toys in ios5

Message 8 of 10 (13,011 Views)
by: spacedayzee
on: 19/01/2012 | 14:47

I had this problem this week too.  Using the phone and sending text messages have been fine but I have been sending iMessages without realising I was using the temporary GiffGaff number.  Don't ask an agent as you will wait 24 hours to be told to post your message in the community. Smiley Tongue

 

I finally fixed it - as uw_photographer says above.  This is what I did:

 

1. Go to Settings

2. Select Messages

3. Under iMessage look at 'Receive At'

4. Click Addresses > is the number shown incorrectly here?  Is it greyed out too?

 

If yes and yes:

 

5. Go to back to Settings > Phone

6. My Number is now editable

7. Edit and save your number

8. Go back to Messages > Receive At

9. Notice is is now verifying > Once this is finished it should work fine on your ported number. 

Remembers to click 'Accept as Solution' when you get the right answer.
Message 9 of 10 (11,762 Views)
by: haztaz
on: 17/01/2013 | 18:04

Me too but turned Imessage off, restarted IPhone and reset Imessage and it came onto correct (new) number !!!

Message 10 of 10 (7,921 Views)