Knowledge Base
Community

iPad Mobile Data not working since I connected to my phone hotspot when abroad

Started by: ipadglenys
On: 12/01/2019 | 15:00
Replies: 8
Reply

Go to best answer
by: ipadglenys
on: 12/01/2019 | 15:00

I travelled to Spain last October - my phone connected to the wi-fi where i was staying but my iPad would not so I made my phone into a hotspot & connected via that to use my iPad. I also connected to roaming data services. I haven't been able to connect to a mobile network since returning to the UK. I have tried resetting the giffgaff APN settings several times. I have tried removing the giffgaff profile & re-installing. I have upgraded iOs to 12. Nothing has worked. My iPad has used some data from my gigabag but very little - I certainly cannot use Safari when not connected to wifi, just get the 'Could not activate mobile data network' message. Hoping someone can help please !  

Message 1 of 9
1 BEST ANSWER

Accepted Solutions
by: sloz
on: 12/01/2019 | 15:48
@ipadglenys
Hi do you see a connection symbol
(3G, 4G, H, E, gprs)
Next to the signal bars
And do you get a connection if you switch to 3G?

Can you complete these steps 
Go to 
Settings 
General 
Profiles 
And remove any vpn and data profiles there 

Go to 
Settings 
General 
Reset 
And click reset network settings 

Your iPad will switch off and restart automatically in a few minutes 

Once it restarts go to the data settings and check that 
Giffgaff.com is set as the apn

Try a connection using both 4G and 3G,

Go to settings again and change the apn to 
Mobile.o2.co.uk 

And try a connection again with both 4G and 3G
Get a free giffgaff Sim
Message 5 of 9
by: bilal86440
on: 12/01/2019 | 15:12
@ipadglenys
I suggest you Reset your Network Settings on your iPad

Tap Settings > General > Reset > Reset Network Settings. This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

Please follow this http://community.giffgaff.com/t5/Settings-for-your-device/giffgaffer-s-guide-to-iPad/ta-p/4584240 guide to manually configure your iPad with the correct APN/Data settings
Get a free giffgaff Sim
Message 2 of 9
Highlighted
by: aaronhank
on: 12/01/2019 | 15:26
Some of the settings (e.g. proxies) are not available to iPad users. For this reason, we invite you to use this method only when you are unable to use any of the two methods above. @ipadglenys

Go to Settings
Go to Mobile (or Cellular)
Go to Mobile (or Cellular) Data
Under Mobile (or Cellular) Data Network, enter the the Internet Settings
Switch your data off and on
Message 3 of 9
by: ipadglenys
on: 12/01/2019 | 15:36
Reset and install worked fine but didn't fix problem I'm afraid. Tried turning everything off & on again, no joy.
Message 4 of 9
by: sloz
on: 12/01/2019 | 15:48
@ipadglenys
Hi do you see a connection symbol
(3G, 4G, H, E, gprs)
Next to the signal bars
And do you get a connection if you switch to 3G?

Can you complete these steps 
Go to 
Settings 
General 
Profiles 
And remove any vpn and data profiles there 

Go to 
Settings 
General 
Reset 
And click reset network settings 

Your iPad will switch off and restart automatically in a few minutes 

Once it restarts go to the data settings and check that 
Giffgaff.com is set as the apn

Try a connection using both 4G and 3G,

Go to settings again and change the apn to 
Mobile.o2.co.uk 

And try a connection again with both 4G and 3G
Get a free giffgaff Sim
Message 5 of 9
by: headcases
on: 12/01/2019 | 15:53
can you try another giffgaff sim
If I helped click ''solutions and kudos'' thanks

Sent from my iphone 6s
Message 6 of 9
by: ipadglenys
on: 12/01/2019 | 16:54
Thank you sloz,

I do get a 4G or 3G symbol when I turn off 4G - interestingly my 3G connection is working!
I then removed all profiles - there was only one i.e. giffgaff - reset network settings - then i had to Install the giffgaff APN settings again. 4 G still does not work. Changing the apn to Mobile.o2.co.uk doesn't make any difference, 3G works but 4G does not.
Message 7 of 9
by: ipadglenys
on: 12/01/2019 | 16:55
Headcases - I don't have another giffgaff sim in the house I'm afraid.
Message 8 of 9
by: sloz
on: 12/01/2019 | 17:02

@ipadglenys wrote:

Thank you sloz,

I do get a 4G or 3G symbol when I turn off 4G - interestingly my 3G connection is working!
I then removed all profiles - there was only one i.e. giffgaff - reset network settings - then i had to Install the giffgaff APN settings again. 4 G still does not work. Changing the apn to Mobile.o2.co.uk doesn't make any difference, 3G works but 4G does not.

@ipadglenys

I don't have an iPad, but from feedback, others have found that 3g works with both the giffgaff and o2 apn

But

4G only works with the o2 apn, 

 

 

Get a free giffgaff Sim
Message 9 of 9