Get Help
Community

iPhone 4S - iOS 5.1 - iMessage not working?

Started by: enzoman
On: 09/03/2012 | 15:21
Replies: 8
Reply

Go to solution
by: enzoman
on: 09/03/2012 | 15:21

I updated to iOS 5.1 and used the txt message GiffGaff sent me for my internet settings - I can go online using 3G but when I go into Settings / Messages - and try swicth on iMessage just asks me to sign in, time and time again?

 

I'm using iMessage on my Messages App on the Mac, so iMessage does work fine just not on my iPhone after the update, any suggestions?

 

Cellular Data:

APN: giffgaff.com

Username: giffgaff

Password: password

 

MMS:

APN: giffgaff.com

Username: giffgaff

Password: password

MMSC: http://mmsc-ac.mms.o2.co.uk:10021/mmsc

MMS Proxy: 193.113.200.195:8080

MMS Max Message Size: 2097152

 

These are my settings...

 

Message 1 of 9 (5,004 Views)
1 ACCEPTED SOLUTION

Accepted Solutions
by: shabbako1
on: 09/03/2012 | 15:23
Best Answer
Accepted by topic author enzoman
‎21-08-2015 01:01
After lots of tests, we worked out that iphone A had "giffgaff profile" for some reason. iphone B and C did not.

Solution:
Settings > General > Profile --- unsigned giffgaff profile present
Delete this profile
Settings > General > Network > Cellular Data Network
Re-input the giffgaff settings: LINK
Reset the iphone
Done!
Good luck
FREE NORMAL SIM OR MICRO SIM WITH £5 FREE CREDIT CLICK ON THE BANNER
Get a free giffgaff Sim
Message 2 of 9 (5,029 Views)
by: shabbako1
on: 09/03/2012 | 15:23
Best Answer
Accepted by topic author enzoman
‎21-08-2015 01:01
After lots of tests, we worked out that iphone A had "giffgaff profile" for some reason. iphone B and C did not.

Solution:
Settings > General > Profile --- unsigned giffgaff profile present
Delete this profile
Settings > General > Network > Cellular Data Network
Re-input the giffgaff settings: LINK
Reset the iphone
Done!
Good luck
FREE NORMAL SIM OR MICRO SIM WITH £5 FREE CREDIT CLICK ON THE BANNER
Get a free giffgaff Sim
Message 2 of 9 (5,030 Views)
by: adnanasim80
on: 09/03/2012 | 15:23

Fixed the issue by doing:

1) Switched off Face Time (Setting -> FaceTime-> FaceTime OFF)
2) Switched off iMessage(Setting -> Messages->iMessage OFF)
3) Switched on iMessage

4) Switched on Face(Same “Verifying” as with iMessage, but tooktwo attempts).
6) Power Cycled the ‘phone and re-synced to updateiTunes If necessary

Message 3 of 9 (4,985 Views)
by: morvin
on: 09/03/2012 | 15:25
Do a clean install using iTunes and setup iMessage from scratch. It will work
Get a free Giffgaff Sim
Please give 'KUDOS' if you like my post. If my answer helped then please click 'Accept as Solution'
Message 4 of 9 (4,982 Views)
by: enzoman
on: 09/03/2012 | 15:25

The link you added - isn't working.

Message 5 of 9 (4,981 Views)
by: craigbutcheris
on: 09/03/2012 | 15:28

i had to delete the giffgaff setting profile i downloaded this morning after i updated my iphone to 5.1because the internet didnt work correctly after downlaoding the profile.

 

I solved the problems by deleteing the profile and inputting the setting manually which you can find on here if you search for iphone setting.

 

Job done all working fantastically again :-)

Message 6 of 9 (4,967 Views)
by: adnanasim80
on: 09/03/2012 | 15:30

The solution is to delete profile in Settings>General>Profile (I think that's where profile is) and enter the APN settings again! Reboot then it should work

Message 7 of 9 (4,958 Views)
by: rachiedanielle89
on: 11/03/2012 | 08:22

I've deleted the profile and googled the APN Settings, re-entered those and rebooted, and still not getting imessage. Please help Smiley Sad

Message 8 of 9 (4,281 Views)
by: enzoman
on: 11/03/2012 | 08:37
Make sure all your MMS settings are the same as the ones I made in my first post?

Go to Settings / Messages - turn off iMessage and back on again.

In Settings / Messages - go down to receive at - Caller ID - change it to your email.

If all that doesn't work try turning off FaceTime and iMessage and repeat what I just suggested.
Message 9 of 9 (4,269 Views)