Knowledge Base

iPhone 4s OS6 - After Network Reset - Enter giffgaff cellular data - wifi still greyed out

Started by: foonle
On: 25/08/2013 | 08:49
Replies: 8

by: foonle
on: 25/08/2013 | 08:49

I have an iphone 4s running OS6.


My wifi stopped working in that I could select it but there were no wifi sources listed.


I saw online that a network reset might fix the problem, so I did a network reset and that did fix the problem. The wifi was working and wifi sources were listed.


However, the cellular data was also reset.


So I entered the cellular data:

Cellular Data


Username giffgaff

Password password


Visual Voicemail (no change)


Username vertigo

Password (unchanged)




Username giffgaff

Password password

(other setting unchanged)


Then I turned by phone power off and on.


Now I have a problem. The wifi button is disabled (greyed out in the off position) on my phone, so I can't turn wifi on. It seems that entering the giffgiff cellular data has caused this.


Has anyone seen this specific issue? Can anyone offer any useful advice please?

Message 1 of 9
by: redjay22
on: 25/08/2013 | 08:51
Try rebooting your phone again.

You may need to restore your iPhone of this issue continues.
Please Kudos me if i helped!
Get a free Giffgaff Sim
Message 2 of 9
by: mykiel78
on: 25/08/2013 | 09:02
Try the app instead mate:

Download the mygiffgaff APP via wifi and install the settings from within the app by tapping on

More > APN settings > install settings
Message 3 of 9
by: foonle
on: 25/08/2013 | 09:05

Rebooted iphone again. Didn't work, same issue.


Just to be clear, from reading online there are 2 fixes when wifi doesn't work. The first is to reset Network settings, the second is to restore iPhone. 


I have tried these and the Network settings reset works. The wifi starts working just fine.


However, when I change the cellular data and enter giffgaf details, then reset my phone, the wifi is disabled.


I just wondered if this could be something to do with the giffgaff cellular data settings?

Message 4 of 9
by: mykiel78
on: 25/08/2013 | 09:13
I have the same settings as you on my 4s mate albeit using the app's APN instead and working fine with wifi as well.

Has it worked ok previously?
Message 5 of 9
by: jeffpeps
on: 25/08/2013 | 09:17
Install the my Giffgaff app from the App Store all the settings are on there under MORE , click on apn settings , then install settings 🇬🇧
Message 6 of 9
by: foonle
on: 25/08/2013 | 09:24



I did another Network reset so that wifi would work again, which reset my settings including cellular settings.


I installed the new my giffgaff app as suggested (I still had the old one on my phone).


Under More >> APN Settings there is the cellular data settings. I installed these.


This installation set up the following:


Cellular Data:


Username vertigo (not giffgaff)

Password password


I then had to manually change the MMS details to:



It seems that the difference between my old settings and my new is the username. I previously used giffgaff. Not it seems I need to use vertigo.


Thanks for your help, I'll update if it messes up again.


Message 7 of 9
by: mykiel78
on: 25/08/2013 | 09:27
That's it! Glad you are sorted Smiley Happy
Message 8 of 9
by: jeffpeps
on: 25/08/2013 | 09:31
Nearly all iPhones are the same , vertigo is the better username , seems to work better 🇬🇧
Message 9 of 9