Get Help
Community

mobile data not working!!!!

Started by: mussamabintishaq
On: 06/11/2012 | 16:07
Replies: 12
Reply

Go to best answer
by: mussamabintishaq
on: 06/11/2012 | 16:07

my mobile internet has stopped working on my iphone 4. everytime i try to use safari it says mobile "could not activate mobile data metwork, you are not suscribed to a mobile data service"

 

HELP PLEASE. im actually considering leaving giffgaff due to all the problems!!!

Message 1 of 13
1 BEST ANSWER

Accepted Solutions
by: rebelyell
on: 06/11/2012 | 16:11
Best Answer
These are the iPhone data settings (you may have to redo them if your phone has been updated recently or they have become corrupted):

Settings>General>Network>Cellular Data Network
APN - giffgaff.com
Username - giffgaff
Password - password

MMS settings:
APN: giffgaff.com
Username: giffgaff
Password: password
MMSC: http://mmsc-ac.mms.o2.co.uk:10021/mmsc
MMS Proxy: 193.113.200.195:8080
MMS Max Message Size: 2097152

Next you should go to Settings>Messages
and check that "MMS Messaging is turned ON
Then Switch your iPhone OFF and then back on.
Message 10 of 13
by: giffgafful
on: 06/11/2012 | 16:09

Delete the giffgaff APN settings, restart the phone, put them back and restart the phone again. See if that solves it.

Message 4 of 13
by: joanne7795
on: 06/11/2012 | 16:09

try re boot or pur setts in again

Message 5 of 13
by: aijay2010_a
on: 06/11/2012 | 16:09

Can you recheck your internet settings? My mobile data is working on an iPhone 4s. Did you recently upgrade your iOS?

Get a free Giffgaff Sim
Message 6 of 13
by: djbonner07
on: 06/11/2012 | 16:10
[ Network Issues & More ]


'Quick Options to try'

1, See if theres any problems in your area http://status.o2.co.uk/

giffgaff operates as a mobile virtual network operator using the O2/Telefonica network


2, Turn On Airplane Mode (if you have this option) And then turn Off after about 20 sec

[ Alternatively ]
Take the battery out for 30 sec and then place it back in and power up (not for Iphone users Etc)

3, Try : http://is.gd/manualroam

4, Or hand clean the sim very carefully



[ Well worth a try if its a data / internet issue ]

[ Internet Settings Problems ]

Try deleting any old or even giffgaff wap/mms settings if you have them already, Delete (data) / (wap) (internet) settings then power off your phone then back on again and retry the settings and see if that works


[ Quick Internet Settings & More if you get stuck at all ]

Try my Internet /MMS Settings/Tips/Info/Apps Guide: http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/Newbie-Quick-Internet-Guide/m-p/2066679
Get a free giffgaff Sim
Message 7 of 13
by: hotsteel
on: 06/11/2012 | 16:10
Check O2 status, the local mast maybe not working to well. Also I find just restarting phone can fix
Get a free giffgaff Simhere sat in front of my aging laptop
Message 8 of 13
by: emiles
on: 06/11/2012 | 16:11
check you either have airtime credit or a goody bag supporting internet data, otherwise check you have the correct giff gaff settings, you can get these from www.giffgaff.com
Remember to give Kudos to helpful answers and mark an answer as the solution! Smiley Wink
http://giffgaff.com/orders/affiliate/emiles
Get a free giffgaff Sim
Message 9 of 13
by: rebelyell
on: 06/11/2012 | 16:11
Best Answer
These are the iPhone data settings (you may have to redo them if your phone has been updated recently or they have become corrupted):

Settings>General>Network>Cellular Data Network
APN - giffgaff.com
Username - giffgaff
Password - password

MMS settings:
APN: giffgaff.com
Username: giffgaff
Password: password
MMSC: http://mmsc-ac.mms.o2.co.uk:10021/mmsc
MMS Proxy: 193.113.200.195:8080
MMS Max Message Size: 2097152

Next you should go to Settings>Messages
and check that "MMS Messaging is turned ON
Then Switch your iPhone OFF and then back on.
Message 10 of 13