Get Help

my Internet won't work on my samsung galaxy s4

Started by: leannehindle
On: 17/08/2013 | 10:53
Replies: 5

by: leannehindle
on: 17/08/2013 | 10:53
My Internet won't work on my Samsung galaxy s4
Message 1 of 6
by: staceyw13
on: 17/08/2013 | 10:54

See your other post here > for answers.

If I answered your question set as " BEST ANSWER " also give "KUDOS" if i helped you.
Get a free giffgaff Sim
Message 2 of 6
by: mathew40
on: 17/08/2013 | 10:58
Hi there.
Firstly,if you could please turn your device OFF and wait 5 minutes,then turn your device ON again,as this can help in most cases.
If your issue has not been resolved,
check the signal in your area,by visiting or clicking onto the link below.

( still not fixed )

You will now need to perform,a manual roam.

1) Go to your phones "settings".

2)Select mobile network options.

3) Change the Network Selection Mode from Automatic to Manual

A list of available networks will be displayed after a few moments.

4) Select any other network that is not your home provider network. After a few moments you will see "No Service" on the display.

5)Now select your home provider(which is o2) network and change the selection back to Automatic.

Also make sure that you either have remaining data left on your goodybag,or enough credit.
Check here.

Finally,take another look at your "settings".

Please click onto the link below to take a look at a great guide on,how to fix your internet and MMS "settings"
Get a free giffgaff Sim
Message 3 of 6
by: bengalknights
on: 17/08/2013 | 10:59
For android settings see or install giffgaff apn app or tweaker from play using wifi
Get a free giffgaff Sim
Message 5 of 6
by: sullyman524
on: 17/08/2013 | 11:16

have you got credit/goodybag?


have you entered the settings?

Have I helped? If yes, please give me KUDOS, this is to the left of the post underneath my name.If I have solved your problem or answered your question, please click accept as solution on my post
Get a free giffgaff Sim
Message 6 of 6