Get Help

nokia lumia 520

Started by: riddla82
On: 09/03/2014 | 07:03
Replies: 40

Go to best answer
by: riddla82
on: 09/03/2014 | 07:03
Right i joined giffgaff on the pretence its the cheapier more affordable network atm. Ive ordered my sim, registered it, put the settings into the Nokia lumia 520 as said here in the community. My issues are the loss of services, internet is none existing during the day, my phone signal goes all the time.. And you say you use the o2 network?? I was on o2 before joining and never lost internet during the day, and my signal was really gd. So i can not understand the issues. Is the service not as gd as the four best sellers o2/vodafone/EE/orange ??
or it is my area? My phone?? I don't understand but when i use internet for my photography work i might as well stayed with o2 and paid the higher rate for calls and internet.
Message 1 of 41

Accepted Solutions
by: riddla82
on: 11/03/2014 | 16:58
I put aim into my galaxy s3mini on the o2 network inputted settings from here for apn and its worked. Lack of signal during the day is annoying thou... ive checked with o2 status says im in a gd signal area. So I dont get the issue. My nokia lumia now has my o2 sim in and is working perfectly fine. .. so no idea. Might just bite the bullet and say I'll keep it in my Android phone with this sim..
Message 41 of 41
by: natty88
on: 09/03/2014 | 07:06 pop your postcode in to check problems in your area then try rebooting phone
Get a free giffgaff Sim
Message 2 of 41
by: mathew40
on: 09/03/2014 | 07:07
Hi there,firstly,if you could please turn your device OFF and wait 5 minutes,then turn your device ON again,as this can help in most cases.If your issue has not been resolved,check the signal in your area,by visiting or clicking onto the link below.

( still not fixed )

You will now need to perform,a manual roam.

1) Go to your phones "settings".

2)Select mobile network options.

3) Change the Network Selection Mode from Automatic to Manual

A list of available networks will be displayed after a few moments.

4) Select any other network that is not your home provider network. After a few moments you will see "No Service" on the display.

5)Now select your home provider(which is o2) network and change the selection back to Automatic.

Get a free giffgaff Sim
Message 3 of 41
by: natty88
on: 09/03/2014 | 07:07 as your phone is windows please double check settings with these please
Get a free giffgaff Sim
Message 4 of 41
by: natty88
on: 09/03/2014 | 07:12
Also try switching of automatic network search m8 as that can cause drop outs between networks
Get a free giffgaff Sim
Message 5 of 41
by: riddla82
on: 09/03/2014 | 07:16
Right in running windows 8.1 the black edition update on my Nokia lumia 520. I have tried all of your suggestions above and still not sure. IM in a gd o2 signal area. With 4g capabilities in this area also so im still confused..
Message 6 of 41
by: mgodfrey19742
on: 09/03/2014 | 07:16
I use giff gaff on a lumia 800 & 920 without any issues. It possibly is a phone fault so try a hard reset if all else fails.
Message 7 of 41
by: natty88
on: 09/03/2014 | 07:18
have you got another sim you could try in phone to see if same m8
Get a free giffgaff Sim
Message 8 of 41
by: natty88
on: 09/03/2014 | 07:22
also try switching to 2g for 5 mins then reselect 3g network
Get a free giffgaff Sim
Message 9 of 41
by: riddla82
on: 09/03/2014 | 07:25
IM awaiting 3 Sims for friends from giffgaff atm, i have tried my old o2 sim and no problems at all, surfs the web, no loss of signal. Ive tried a vodfone sim also. And the same if anything i had faster inter with Vodafone sim. Which used a hsdpa connection.

mgodfrey19742 could u post the settings your using at all, and hard reset was my last option really.
Message 10 of 41