Knowledge Base
Community

Cubot X12 Android 5.1 settings

Started by: toltec121
On: 12/07/2015 | 13:02
Replies: 5
Reply

by: toltec121
on: 12/07/2015 | 13:02
Have just bought this superb 4g phone for 80 pounds. Highly recommended.

It has Android 5.1 and the setting up is somewhat different to what is listed on here.

Settings > Wireless & Networks > More > Cellular networks > Access point names

I found that it had by default put in some O2 settings so I actually changed one of those, rather than set a
new one.

Set up as usual

Name giffgaff
APN giffgaff.com
Username giffgaff
Password (leave blank)
MMS proxy 82.132.254.1
MMC 234
MNC 10

After that go back to cellular networks > Preferred Network Type and set 3G or 4G depending on your data plan.

Last thing is to go back to Wireless & Networks > Cellular Data and switch it on.

Worked for me Smiley Happy
Message 1 of 6
by: xtracash4u
on: 12/07/2015 | 13:09
I bought the mlais m52 nice phone cost a bit more but its octacore, so very fast
Get a free giffgaff Sim
Message 2 of 6
by: toltec121
on: 12/07/2015 | 13:24
Is it 4g ? My wife has an octa core Cubot X6 but I bought the X12 because it is 4g
Message 3 of 6
by: sarahbanahnah
on: 14/07/2015 | 09:15

Is it better than Samsungs?

Get a free giffgaff Sim
Click the banner above for a free giffgaff SIM with free airtime credit of £5.
If you can't see it, then click the link below:
http://giffgaff.com/orders/affiliate/sarahbanahnah
Message 4 of 6
by: bullphit
on: 16/07/2015 | 08:39
Sound like good phones
Get a free giffgaff Sim
Message 5 of 6
by: davecs
on: 17/12/2015 | 23:37 edited: 10/01/2016 | 13:12

Worked for me though I set up a new setting instead of amending an existing one. Then the name I gave it "GiffGaff" had to be typed in by hand. But yes, perfect!!

 

By the way: It defaulted to "preferred type" as 4G but I only got 3G. So I changed it to 3G and then back again to 4G and it worked just fine.

 

Message 6 of 6