Get Help
Community

Facebook on Giffgaff with a Blackberry

Started by: darrenpainter
On: 06/08/2010 | 14:01
Replies: 6
Reply

Highlighted
by: darrenpainter
on: 06/08/2010 | 14:01 edited: 16/02/2012 | 13:29

You may not be aware if you are new to the world of Blackberry, that many services supplied by RIM, the makers of Blackberry, do not work without what is called BIS, or Blackberry Internet Services. This is an add on to your usual data tariff that some providers such as T-mobile, Orange, and since Monday O2 can enable.

 

Giffgaff do not as yet have such an add on to their PAYG or Goody Bag tariff, so as a result Blackberry users on Giffgaff have to be creative in obtaining work-arounds to get many applications working.

 

One such application is the Blackberry Facebook client. The Blackberry client for Facebook is available from the Blackberry website and also pre-installed on some devices. However if it installed to a Blackberry without BIS support it will fail to run reporting a connection error.

 

The solution is to revert back to v1.6

 

In trying to get v1.6 onto my Curve 8520, I tried navigating to the Blackberry.com site and using the direct download link for the older v1.6, however I soon discovered that this link will test your handset for compliance and will refuse to load saying that your device is not compatible.

 

So for a while I suspected that the only way to access the site would be via the mobile web version on http://m.facebook.com

 

However some more research turned up a copy of the v1.6 client in alx/cod format which can be manually installed through Application Loader on the Blackberry Desktop Manager software

 

Assuming you have followed the other guides on the forum such as Giffgaffing a Blackberry you should already have enabled TCP on your device, but if not then please visit this link first.

 

http://community.giffgaff.com/t5/Learn-giffgaff-Top-Tips/How-to-GiffGaff-a-Blackberry/td-p/12233/

 

Then visit the following site via your PC, and download the right version of Facebook based on the current firmware of your device.

 

http://forums.crackberry.com/f35/ota-facebook-1-6-0-21-4-6-alx-cod-341636/

 

Remove any existing v1.7 Facebook client from your device

 

Install v1.6 to your handset and you should now have Facebook access.

Message 1 of 7
by: u_ghafoor
on: 23/04/2011 | 18:05 edited: 23/04/2011 | 18:07

UPDATE:

 

Facebook 1.6 no longer works on Blackberry Operating System 6. This is because the OS requires you to have version 2.0 minimum.

 

Trying to install 1.6 through BBSAK resulted in nothing for me. I couldn't find the facebook icon in any of the menus.

According other forums, people who have managed to get an icon to show up are greeted with a force update screen when they try to launch the app.

 

So if you have a Bold 9700 or a Curve 9300 and like your dataplan-less facebookery, don't upgrade to OS6.

Get a free giffgaff Sim
Message 3 of 7
by: diabolic
on: 28/06/2011 | 16:06
This is awesome, i am going to do this for my blackberry and hope for the best Smiley Happy.
Message 4 of 7
by: divefrosty
on: 14/07/2011 | 10:57

Problem for me is that I was up to OS6 with lots of the apps running before I got to the FB app.....has anyone managed to find a way to get version FB 1.9 working?

 

Also we have a date for BB activation? all I hear is this summer but define Summer? Aug? Sept? etc.

Ta

Message 5 of 7
by: u_ghafoor
on: 17/07/2011 | 15:04
Update, there is currently a version beta facebook for blackberry on the blackberry beta site that does not check for a blackberry dataplan.
No one knows when it will come out of beta and be released though.
Get a free giffgaff Sim
Message 6 of 7