Knowledge Base
Community

How to replace the default Samsung Galaxy S4 mini APN that has wrong MMS settings

Started by: iain_english
On: 09/03/2015 | 10:38
Replies: 104
Reply

Go to best answer
by: iain_english
on: 09/03/2015 | 10:38 edited: 05/08/2015 | 23:57

Follow these steps if you are having a problem with MMS messages not sending from your handset because of incorrect default APN settings that cannot be edited.

1. Open Settings/More networks/Mobile networks/Access point names
2. Touch bottom left of screen and Reset to default. A list of operator APN settings will appear.
3. Select O2 Pay and go.
4. Touch + at top right of screen to add a new APN
5. Enter these exact settings in the appropriate fields. Leave other fields as they are.
Name - giffgaff
APN - giffgaff.com
Username - giffgaff
MMSC - http://mmsc.mediamessaging.co.uk:8002
MMS Proxy - 82.132.254.1
MMS Port - 8080
MCC - 234
MNC -10
Authentication type - PAP
APN type - default,supl,mms

6. Touch bottom left of screen and save (*very important step*)
7. Touch circle to right of new giffgaff apn to turn it on (green dot)
8. Your internet signal indicator will activate after a short wait (up to 20 seconds depending on signal).

That's it. You can now send MMS messages.

The steps should also work with any other Samsung handset.

:-)

Message 1 of 105
by: scrappydez
on: 09/03/2015 | 10:46

Nice, glad your sorted.

Get your SIM delivered today by 1st Class Post, yeah boy.
Message 2 of 105
by: formulaone
on: 09/03/2015 | 20:26 edited: 29/03/2018 | 00:05

 


@iain_english wrote:

Follow these steps if you are having a problem with MMS messages not sending from your handset because of incorrect default APN settings that cannot be edited.

1. Open Settings/More networks/Mobile networks/Access point names
2. Touch bottom left of screen and Reset to default. A list of operator APN settings will appear.
3. Select O2 Pay and go.
4. Touch + at top right of screen to add a new APN
5. Enter these exact settings in the appropriate fields. Leave other fields as they are.
Name - giffgaff
APN - giffgaff.com
Username - giffgaff
MMSC - http://mmsc.mediamessaging.co.uk:8002
MMS Proxy - 82.132.254.1
MMS Port - 8080
MCC - 234
MNC -10
Authentication type - PAP
APN type - default,supl,mms

6. Touch bottom left of screen and save
7. Touch circle to right of new giffgaff apn to turn it on (green dot)
8. Your internet signal indicator will activate after a short wait (up to 20 seconds depending on signal).

That's it. You can now send MMS messages.

The steps should also work with any other Samsung handset.

:-)


O.M.G !!

 

Your a legend mate, I've been trying to find an alternative route on using this particular phone for while now, This actually worked!

 

I'll now be recommending this to others on the community forum, That are having problem's with sending an MMS message on this particular phone,

 

As this phone is 'auto' setup when the SIM is inserted, I found if you select the 'giffgaff' APN instead of the O2 pay and go, The settings are messed up, Such as the MMSC - part, Which is showing as (http://mmsc.mms.mediamessaging.co.uk:8002) When in fact it should be as the following (http://mmsc.mediamessaging.co.uk:8002)

 

I put this down to either 'samsung' at fault or the makers of 'android' for making this terrible mistake, Together with NOT being able to delete an APN on this device, Which is ridiculous lol, Unless of course you reset the settings back to 'default'

 

This issue only occurs on 'some' make phone's. Therefore it's not a network related issue. (It's more of a manufacturer / OS related issue), Giffgaff are aware and they are currently looking in to this  See below for an update!

 

Well done on this !!!!

 

Smiley Happy

 

.................

 

Here's a link that also may be of some help;

 

https://community.giffgaff.com/t5/Tips-Guides/Samsung-Phones-not-sending-or-receiving-MMS-Picture-me...

 

......................

 

@iain_english 

 

THIS APPLIES TO ANY DEVICE / PHONE

 

TRY USING THE O2 PAY & GO APN (THIS WILL NOT EFFECT YOUR GIFFGAFF SERVICES AND THEY WILL WORK AS NORMAL AS THEY DO NOW)

 

THIS WILL RESOLVE ANY ISSUES THAT YOU MIGHT BE HAVING WHEN SENDING AN MMS MESSAGE FROM YOUR PHONE.

 

1) Reset your Apn settings to default (a list of network operators should now appear on your phone's screen)

2) Choose an O2-UK Apn (O2 PAY & GO)

 

..... If you prefer; after you have reset your apn settings to default and chosen O2-UK's default apn. You can then create a new giffgaff apn, with the correct apn settings (remember to select this one afterwards), you may need to turn your phone off and then back on

 

.........................................................

 

  • Name - giffgaff
  • APN - giffgaff.com
  • Username - giffgaff
  • Password - [leave blank]
  • Server - http://mmsc.mediamessaging.co.uk:8002
  • MMSC - http://mmsc.mediamessaging.co.uk:8002
  • MMS Proxy - 82.132.254.1
  • MMS Port - 8080
  • Authentication type - PAP or CHAP
  • APN type - default,supl,mms (Depending on your android system and if you are running on lollipop 5.0 or above) You MAY need to use the following: default* Or default,* Or *

 

Their are some other points that you will need to take into account prior to sending an MMS message from your phone.

  • Ensure that any WIFI connection is disabled on your phone and your mobile data connection is enabled.

 

  • You will need airtime credit available on your giffgaff account prior to sending an MMS message and these are charged at 16p per message. (PLEASE NOTE: To send an MMS message from your phone - Goodybag Allowances are NOT Included)

 

  • If your phone has a built in Data useage and you have Background data enabled - This will need to be disabled as this can block you from sending/receiving an MMS message.

 

  • You will also need a GOOD data connection EG: 3G/H/H+/4G prior to sending an MMS message - Otherwise it may fail to send if your on 2G/EDGE or might be much slower to send.

 

  • Also, Regarding large photos/pictures, The phone will usually either downsize these prior to sending an MMS message OR they will simply fail to send altogether, The maximum size of the picture must be 300KB or lower.

 

I can't send or receive MMS, why?

 

Internet and MMS settings (APN) guide

 

................

 

A long awaited answer ; Regarding the MMS issue ~ This has been confirmed by giffgaff / O2

 

"""" We have an answer! 

So, the incorrect settings can happen to any device that is older than 3 years(we cannot narrow it down to any specific makes but for iPhones anything above 5s/c should be fine ) and as you folks spotted it has very much to to with this line in the settings:

MMSC - http://mmsc.mms.mediamessaging.co.uk:8002
which is incorrect. 

The correct setting is:
MMSC - http://mmsc.mediamessaging.co.uk:8002

So technically, by removing the 'mms' part everything should be ok for older devices. We cannot seem to be able to do that automatically for some devices older than 3 years. """

 

SEE HERE;

 

https://community.giffgaff.com/t5/Service-Updates/EXTENDED-Planned-fix-implementation-for-legacy-int...

 

............

 

This link may be of some help to; (as I opened up a thread in Tips & Guides), for any ones reference, on the above)

 

https://community.giffgaff.com/t5/Tips-Guides/Unable-To-Send-An-MMS-MULTIMEDIA-MESSAGING-SERVICE-On-...

Get a free giffgaff Sim
Message 3 of 105
by: iain_english
on: 09/03/2015 | 23:27

@formulaone Glad I managed to help.

Knew there had to be a better way than a 3rd party app and just had a mess around with settings.
As luck would have it, this worked :-)

Message 4 of 105
by: badam42
on: 23/03/2015 | 22:46

Just wanted to add my belated thanks too. Works a treat. The pictures (and smileys) sent this way appear to think they are videos though. There is a small "play" icon on the message and when pressed the still picture behaves like a video file i.e. shows in a video player and has a five second timeline.

 

Works though!

 

Many thanks again.

Message 5 of 105
by: kevchip
on: 11/04/2015 | 16:07
Many many thanks Iain I've been tearing my hair out trying to get mms working. I was about to give up!!!!!!!!!
Message 7 of 105
by: chuckypie
on: 24/04/2015 | 06:52
Thanks, it is now working!! So happy!
Message 8 of 105
by: bintymins
on: 06/05/2015 | 13:24

Thanks so much Iain!!

 

I got a new Samsung galaxy A3 yesterday & spent the entire day trying to set it up only to find that I couldn't send a long text that converted to MMS. 

 

I'd always been able to do it on my S3 mini and I thought I was going up in the world with the A3.... until I started reading all the MMS problems that people were having with new SIMs / phones......! Boy, did my heart sink!

 

Thank you Heart - you're a lifesaver!! Smiley LOL

Message 9 of 105
by: formulaone
on: 06/05/2015 | 14:27

@bintymins wrote:

Thanks so much Iain!!

 

I got a new Samsung galaxy A3 yesterday & spent the entire day trying to set it up only to find that I couldn't send a long text that converted to MMS. 

 

I'd always been able to do it on my S3 mini and I thought I was going up in the world with the A3.... until I started reading all the MMS problems that people were having with new SIMs / phones......! Boy, did my heart sink!

 

Thank you Heart - you're a lifesaver!! Smiley LOL


@bintymins

 

Pleased to hear that this worked for you too! Smiley Very Happy

Get a free giffgaff Sim
Message 10 of 105